summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-03 21:53:41 -0500
committerMatt Turner <mattst88@gentoo.org>2023-03-03 22:16:40 -0500
commit3c7e08ea1ca583d762f51215780dadf1d31d1c10 (patch)
treee7cf86ef3e3d491ba30ffe6cfb001d5ebf2f602a /media-libs/libva-intel-media-driver
parentmedia-libs/gmmlib: Version bump to 22.3.4 (diff)
downloadgentoo-3c7e08ea1ca583d762f51215780dadf1d31d1c10.tar.gz
gentoo-3c7e08ea1ca583d762f51215780dadf1d31d1c10.tar.bz2
gentoo-3c7e08ea1ca583d762f51215780dadf1d31d1c10.zip
media-libs/libva-intel-media-driver: Version bump to 23.1.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/libva-intel-media-driver')
-rw-r--r--media-libs/libva-intel-media-driver/Manifest1
-rw-r--r--media-libs/libva-intel-media-driver/libva-intel-media-driver-23.1.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/libva-intel-media-driver/Manifest b/media-libs/libva-intel-media-driver/Manifest
index 203bb3a11364..1b05942c4583 100644
--- a/media-libs/libva-intel-media-driver/Manifest
+++ b/media-libs/libva-intel-media-driver/Manifest
@@ -1,2 +1,3 @@
DIST intel-media-22.5.4.tar.gz 27493483 BLAKE2B ac6a93e06eec33edd823b1fd4310cd635f20229ce1ba1d52eb36a11b8fcaf484c836261cb5e8437889208e9b268f29f78a241867629eb517fbada28a314bb4dc SHA512 9e7e4d7f33d0248f3d2288239ca121cd8c748a98587384e69c92aeedf4b9ce7ff585cac06b260713f9cd95936d270c36e6981bc500c2a6bee7276d0e238f4b74
DIST intel-media-22.6.6.tar.gz 28599397 BLAKE2B 3a3449f0af37c431ff1224bb919de3382767044a728603b9fb3343f6a2ed92ec8f9c30796623a17fe64de617816d0961507171c06e41739c9c650145b93439e2 SHA512 8013ecadfc827a89eea6c72e262c220fe05fc11348ab23d46fb703f170d927739b46b21bad5e79fdebde86b646609339d2333eafb7f0798d77f9c64f20203f90
+DIST intel-media-23.1.2.tar.gz 28625961 BLAKE2B bbeb070f22e9642d3a7510edbf34f438d2c817484ebce75ec3debf86498916a9b1c9ee37c721825a2e8041bd52b7a6501a089fc9d71bd3ecfa5ff6b69b5971b0 SHA512 b5f402c209552caaaa4b6f27094230e6dbed15e24e3bb035a543b72277d19d80d02697b9900ede4137a20e4a02c6ecaf498fe4a58ef247a1f880b9ebc9ca3dbb
diff --git a/media-libs/libva-intel-media-driver/libva-intel-media-driver-23.1.2.ebuild b/media-libs/libva-intel-media-driver/libva-intel-media-driver-23.1.2.ebuild
new file mode 100644
index 000000000000..bd08b390fd83
--- /dev/null
+++ b/media-libs/libva-intel-media-driver/libva-intel-media-driver-23.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/media-driver"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ MY_PV="${PV%_pre}"
+ SRC_URI="https://github.com/intel/media-driver/archive/intel-media-${MY_PV}.tar.gz"
+ S="${WORKDIR}/media-driver-intel-media-${MY_PV}"
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~amd64"
+ fi
+fi
+
+DESCRIPTION="Intel Media Driver for VA-API (iHD)"
+HOMEPAGE="https://github.com/intel/media-driver"
+
+LICENSE="MIT BSD redistributable? ( no-source-code )"
+SLOT="0"
+IUSE="+redistributable test X"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=media-libs/gmmlib-22.3.0:=
+ >=media-libs/libva-2.14.0[X?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-21.4.2-Remove-unwanted-CFLAGS.patch
+ "${FILESDIR}"/${PN}-20.4.5_testing_in_src_test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DMEDIA_BUILD_FATAL_WARNINGS=OFF
+ -DMEDIA_RUN_TEST_SUITE=$(usex test)
+ -DBUILD_TYPE=Release
+ -DPLATFORM=linux
+ -DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X)
+ -DENABLE_NONFREE_KERNELS=$(usex redistributable)
+ -DLATEST_CPP_NEEDED=ON # Seems to be the best option for now
+ )
+ local CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}