summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-30 10:13:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-30 10:25:33 +0100
commita4c55be24f9b6345b55f85110abe1ea74d2f3ac5 (patch)
tree961a048b41dd755abf185e0a6e6920109ac7e4df /media-libs/lilv/lilv-0.24.0.ebuild
parentmedia-libs/lv2: bump to 1.14.0 (diff)
downloadgentoo-a4c55be24f9b6345b55f85110abe1ea74d2f3ac5.tar.gz
gentoo-a4c55be24f9b6345b55f85110abe1ea74d2f3ac5.tar.bz2
gentoo-a4c55be24f9b6345b55f85110abe1ea74d2f3ac5.zip
media-libs/lilv: bump to 0.24.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'media-libs/lilv/lilv-0.24.0.ebuild')
-rw-r--r--media-libs/lilv/lilv-0.24.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/lilv/lilv-0.24.0.ebuild b/media-libs/lilv/lilv-0.24.0.ebuild
new file mode 100644
index 000000000000..0c42b1d0f878
--- /dev/null
+++ b/media-libs/lilv/lilv-0.24.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit base python-any-r1 waf-utils bash-completion-r1
+
+DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://drobilla.net/software/lilv/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc +dyn-manifest static-libs test"
+
+RDEPEND=">=media-libs/lv2-1.14.0
+ >=media-libs/sratom-0.4.0
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.13.0"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --no-bash-completion \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static") \
+ $(use dyn-manifest && echo "--dyn-manifest")
+}
+
+src_test() {
+ ./waf test || die
+}
+
+src_install() {
+ waf-utils_src_install
+ newbashcomp utils/lilv.bash_completion ${PN}
+}