summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-05-13 16:20:45 +0200
committerMatt Turner <mattst88@gentoo.org>2024-06-05 16:01:31 -0400
commit646cb2d69be268e47c9e3b36f34311476d416937 (patch)
treea1869a1fb65dda10673f1b0b2e6439fdebbc578f /media-libs/mesa
parentmedia-libs/mesa: Depend on dev-python/packaging (diff)
downloadgentoo-646cb2d69be268e47c9e3b36f34311476d416937.tar.gz
gentoo-646cb2d69be268e47c9e3b36f34311476d416937.tar.bz2
gentoo-646cb2d69be268e47c9e3b36f34311476d416937.zip
media-libs/mesa: rename zink -> video_cards_zink
zink is listed among the gallium drivers so mirror that. Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-24.1.0-r1.ebuild10
-rw-r--r--media-libs/mesa/mesa-9999.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/media-libs/mesa/mesa-24.1.0-r1.ebuild b/media-libs/mesa/mesa-24.1.0-r1.ebuild
index 888fd8ec22dd..98068e596279 100644
--- a/media-libs/mesa/mesa-24.1.0-r1.ebuild
+++ b/media-libs/mesa/mesa-24.1.0-r1.ebuild
@@ -46,7 +46,7 @@ LICENSE="MIT SGI-B-2.0"
SLOT="0"
RADEON_CARDS="r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lavapipe lima nouveau nvk panfrost v3d vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lavapipe lima nouveau nvk panfrost v3d vc4 virgl vivante vmware zink"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -55,7 +55,7 @@ IUSE="${IUSE_VIDEO_CARDS}
cpu_flags_x86_sse2 d3d9 debug +llvm
lm-sensors opencl +opengl osmesa +proprietary-codecs selinux
test unwind vaapi valgrind vdpau vulkan
- vulkan-overlay wayland +X xa zink +zstd"
+ vulkan-overlay wayland +X xa +zstd"
RESTRICT="!test? ( test )"
REQUIRED_USE="
d3d9? (
@@ -73,10 +73,10 @@ REQUIRED_USE="
video_cards_lavapipe? ( llvm vulkan )
video_cards_radeon? ( x86? ( llvm ) amd64? ( llvm ) )
video_cards_r300? ( x86? ( llvm ) amd64? ( llvm ) )
+ video_cards_zink? ( vulkan opengl )
video_cards_nvk? ( vulkan video_cards_nouveau )
vdpau? ( X )
xa? ( X )
- zink? ( opengl vulkan )
"
LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.119"
@@ -112,6 +112,7 @@ RDEPEND="
)
vdpau? ( >=x11-libs/libvdpau-1.5:=[${MULTILIB_USEDEP}] )
video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+ video_cards_zink? ( media-libs/vulkan-loader:=[${MULTILIB_USEDEP}] )
selinux? ( sys-libs/libselinux[${MULTILIB_USEDEP}] )
wayland? ( >=dev-libs/wayland-1.18.0[${MULTILIB_USEDEP}] )
${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_intel?,video_cards_nouveau?,video_cards_vc4?,video_cards_vivante?,video_cards_vmware?,${MULTILIB_USEDEP}]
@@ -124,7 +125,6 @@ RDEPEND="
x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/xcb-util-keysyms[${MULTILIB_USEDEP}]
)
- zink? ( media-libs/vulkan-loader:=[${MULTILIB_USEDEP}] )
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
for card in ${RADEON_CARDS}; do
@@ -366,7 +366,7 @@ multilib_src_configure() {
gallium_enable video_cards_virgl virgl
gallium_enable video_cards_vivante etnaviv
gallium_enable video_cards_vmware svga
- gallium_enable zink zink
+ gallium_enable video_cards_zink zink
gallium_enable video_cards_r300 r300
gallium_enable video_cards_r600 r600
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index ca78acc8f2a7..bced699ca70a 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -46,7 +46,7 @@ LICENSE="MIT SGI-B-2.0"
SLOT="0"
RADEON_CARDS="r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lavapipe lima nouveau nvk panfrost v3d vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lavapipe lima nouveau nvk panfrost v3d vc4 virgl vivante vmware zink"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -55,7 +55,7 @@ IUSE="${IUSE_VIDEO_CARDS}
cpu_flags_x86_sse2 d3d9 debug +llvm
lm-sensors opencl +opengl osmesa +proprietary-codecs selinux
test unwind vaapi valgrind vdpau vulkan
- vulkan-overlay wayland +X xa zink +zstd"
+ vulkan-overlay wayland +X xa +zstd"
RESTRICT="!test? ( test )"
REQUIRED_USE="
d3d9? (
@@ -73,10 +73,10 @@ REQUIRED_USE="
video_cards_lavapipe? ( llvm vulkan )
video_cards_radeon? ( x86? ( llvm ) amd64? ( llvm ) )
video_cards_r300? ( x86? ( llvm ) amd64? ( llvm ) )
+ video_cards_zink? ( vulkan opengl )
video_cards_nvk? ( vulkan video_cards_nouveau )
vdpau? ( X )
xa? ( X )
- zink? ( opengl vulkan )
"
LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.119"
@@ -112,6 +112,7 @@ RDEPEND="
)
vdpau? ( >=x11-libs/libvdpau-1.5:=[${MULTILIB_USEDEP}] )
video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+ video_cards_zink? ( media-libs/vulkan-loader:=[${MULTILIB_USEDEP}] )
selinux? ( sys-libs/libselinux[${MULTILIB_USEDEP}] )
wayland? ( >=dev-libs/wayland-1.18.0[${MULTILIB_USEDEP}] )
${LIBDRM_DEPSTRING}[video_cards_freedreno?,video_cards_intel?,video_cards_nouveau?,video_cards_vc4?,video_cards_vivante?,video_cards_vmware?,${MULTILIB_USEDEP}]
@@ -124,7 +125,6 @@ RDEPEND="
x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/xcb-util-keysyms[${MULTILIB_USEDEP}]
)
- zink? ( media-libs/vulkan-loader:=[${MULTILIB_USEDEP}] )
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
for card in ${RADEON_CARDS}; do
@@ -363,7 +363,7 @@ multilib_src_configure() {
gallium_enable video_cards_virgl virgl
gallium_enable video_cards_vivante etnaviv
gallium_enable video_cards_vmware svga
- gallium_enable zink zink
+ gallium_enable video_cards_zink zink
gallium_enable video_cards_r300 r300
gallium_enable video_cards_r600 r600