summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Charles Campbell <rossbridger.cc@gmail.com>2020-08-07 20:24:42 +0800
committerMatt Turner <mattst88@gentoo.org>2020-08-11 12:42:15 -0700
commitd78e6b6318526d579512cae0dd959dc332f303c1 (patch)
tree754376ea82f537684818cf5c250018a8b7099243 /media-libs/mesa
parentprofiles: package.use.mask media-libs/mesa zink and consolidate masks (diff)
downloadgentoo-d78e6b6318526d579512cae0dd959dc332f303c1.tar.gz
gentoo-d78e6b6318526d579512cae0dd959dc332f303c1.tar.bz2
gentoo-d78e6b6318526d579512cae0dd959dc332f303c1.zip
media-libs/mesa: enable option for V3D graphics driver
Closes: https://bugs.gentoo.org/733190 Closes: https://github.com/gentoo/gentoo/pull/17040 Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 311d46e53a90..ebb32fce460a 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -29,7 +29,7 @@ RESTRICT="
"
RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 intel iris lima nouveau panfrost vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 intel iris lima nouveau panfrost v3d vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -62,6 +62,7 @@ REQUIRED_USE="
video_cards_r300? ( gallium x86? ( llvm ) amd64? ( llvm ) )
video_cards_r600? ( gallium )
video_cards_radeonsi? ( gallium llvm )
+ video_cards_v3d? ( gallium )
video_cards_vc4? ( gallium )
video_cards_virgl? ( gallium )
video_cards_vivante? ( gallium gbm )
@@ -430,6 +431,7 @@ multilib_src_configure() {
if use video_cards_freedreno ||
use video_cards_lima ||
use video_cards_panfrost ||
+ use video_cards_v3d ||
use video_cards_vc4 ||
use video_cards_vivante; then
gallium_enable -- kmsro
@@ -437,6 +439,7 @@ multilib_src_configure() {
gallium_enable video_cards_lima lima
gallium_enable video_cards_panfrost panfrost
+ gallium_enable video_cards_v3d v3d
gallium_enable video_cards_vc4 vc4
gallium_enable video_cards_vivante etnaviv
gallium_enable video_cards_vmware svga