summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Słomiński <kacper.slominski72@gmail.com>2024-03-28 04:50:11 +0100
committerSam James <sam@gentoo.org>2024-03-28 04:00:34 +0000
commit5bdff1dfb5cdf6d3c34be3108c514cbdd00eb2e1 (patch)
treee2763430bf9481e0cf266671b0a98af6674db643 /media-libs/noise-suppression-for-voice
parentmedia-libs/libsdl2: try harder with LDFLAGS for tests (diff)
downloadgentoo-5bdff1dfb5cdf6d3c34be3108c514cbdd00eb2e1.tar.gz
gentoo-5bdff1dfb5cdf6d3c34be3108c514cbdd00eb2e1.tar.bz2
gentoo-5bdff1dfb5cdf6d3c34be3108c514cbdd00eb2e1.zip
media-libs/noise-suppression-for-voice: Fix build with Clang
Closes: https://bugs.gentoo.org/925672 Signed-off-by: Kacper Słomiński <kacper.slominski72@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35957 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/noise-suppression-for-voice')
-rw-r--r--media-libs/noise-suppression-for-voice/noise-suppression-for-voice-1.03.ebuild11
-rw-r--r--media-libs/noise-suppression-for-voice/noise-suppression-for-voice-9999.ebuild11
2 files changed, 20 insertions, 2 deletions
diff --git a/media-libs/noise-suppression-for-voice/noise-suppression-for-voice-1.03.ebuild b/media-libs/noise-suppression-for-voice/noise-suppression-for-voice-1.03.ebuild
index 78ff0308a9d3..0fd3b8452a21 100644
--- a/media-libs/noise-suppression-for-voice/noise-suppression-for-voice-1.03.ebuild
+++ b/media-libs/noise-suppression-for-voice/noise-suppression-for-voice-1.03.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="A real-time noise suppression plugin for voice"
HOMEPAGE="https://github.com/werman/noise-suppression-for-voice"
@@ -44,6 +44,15 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
+ # Bug #925672
+ # append-atomic-flags does not work for us in this case, as it can
+ # only test for single integers of given sizes, meanwhile
+ # noise-suppression-for-voice does std::atomic<RnNoiseStats>, where
+ # RnNoiseStats is a struct with 4 uint32_t members.
+ if test-flags-CCLD "-latomic" &>/dev/null; then
+ append-flags -Wl,--push-state,--as-needed,-latomic,--pop-state
+ fi
+
local mycmakeargs=(
-DBUILD_LADSPA_PLUGIN=$(usex ladspa ON OFF)
-DBUILD_LV2_PLUGIN=$(usex lv2 ON OFF)
diff --git a/media-libs/noise-suppression-for-voice/noise-suppression-for-voice-9999.ebuild b/media-libs/noise-suppression-for-voice/noise-suppression-for-voice-9999.ebuild
index 78ff0308a9d3..0fd3b8452a21 100644
--- a/media-libs/noise-suppression-for-voice/noise-suppression-for-voice-9999.ebuild
+++ b/media-libs/noise-suppression-for-voice/noise-suppression-for-voice-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="A real-time noise suppression plugin for voice"
HOMEPAGE="https://github.com/werman/noise-suppression-for-voice"
@@ -44,6 +44,15 @@ DEPEND="
RDEPEND="${DEPEND}"
src_configure() {
+ # Bug #925672
+ # append-atomic-flags does not work for us in this case, as it can
+ # only test for single integers of given sizes, meanwhile
+ # noise-suppression-for-voice does std::atomic<RnNoiseStats>, where
+ # RnNoiseStats is a struct with 4 uint32_t members.
+ if test-flags-CCLD "-latomic" &>/dev/null; then
+ append-flags -Wl,--push-state,--as-needed,-latomic,--pop-state
+ fi
+
local mycmakeargs=(
-DBUILD_LADSPA_PLUGIN=$(usex ladspa ON OFF)
-DBUILD_LV2_PLUGIN=$(usex lv2 ON OFF)