summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-25 12:46:34 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-25 12:46:57 +0100
commit505076c7286643dfde04182f258ead871fa964fc (patch)
tree0492af147174640de809dcce95620e70b80094c6 /media-libs/stk/files
parentdev-db/rqlite: add 9999 ebuild (diff)
downloadgentoo-505076c7286643dfde04182f258ead871fa964fc.tar.gz
gentoo-505076c7286643dfde04182f258ead871fa964fc.tar.bz2
gentoo-505076c7286643dfde04182f258ead871fa964fc.zip
media-libs/stk: bump to 4.5.1
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs/stk/files')
-rw-r--r--media-libs/stk/files/stk-4.5.1/010_all_removeForcedFlags.patch13
-rw-r--r--media-libs/stk/files/stk-4.5.1/020_all_noExamplesOrDemo.patch40
-rw-r--r--media-libs/stk/files/stk-4.5.1/050_all_cxxflags.patch13
3 files changed, 66 insertions, 0 deletions
diff --git a/media-libs/stk/files/stk-4.5.1/010_all_removeForcedFlags.patch b/media-libs/stk/files/stk-4.5.1/010_all_removeForcedFlags.patch
new file mode 100644
index 000000000000..3fcc28fb763c
--- /dev/null
+++ b/media-libs/stk/files/stk-4.5.1/010_all_removeForcedFlags.patch
@@ -0,0 +1,13 @@
+Index: stk-4.4.3/configure.ac
+===================================================================
+--- stk-4.4.3.orig/configure.ac
++++ stk-4.4.3/configure.ac
+@@ -65,7 +65,7 @@ if test "$debug" = "yes"; then
+ else
+ AC_SUBST( debug, [no] )
+ AC_SUBST( cppflag, [] )
+- AC_SUBST( cxxflag, [-O3] )
++ AC_SUBST( cxxflag, [] )
+ AC_SUBST( object_path, [Release] )
+ fi
+ AC_MSG_RESULT($debug)
diff --git a/media-libs/stk/files/stk-4.5.1/020_all_noExamplesOrDemo.patch b/media-libs/stk/files/stk-4.5.1/020_all_noExamplesOrDemo.patch
new file mode 100644
index 000000000000..77d643593b47
--- /dev/null
+++ b/media-libs/stk/files/stk-4.5.1/020_all_noExamplesOrDemo.patch
@@ -0,0 +1,40 @@
+Index: stk-4.5.0/Makefile.in
+===================================================================
+--- stk-4.5.0.orig/Makefile.in
++++ stk-4.5.0/Makefile.in
+@@ -6,35 +6,14 @@ REALTIME = @realtime@
+
+ all :
+ cd src && $(MAKE)
+- cd projects/demo && $(MAKE) libdemo
+-ifeq ($(REALTIME),yes)
+- cd projects/effects && $(MAKE) libeffects
+- cd projects/ragamatic && $(MAKE) libragamat
+- cd projects/eguitar && $(MAKE) libeguitar
+-endif
+- cd projects/examples && $(MAKE) -f libMakefile
+
+ clean :
+ $(RM) -f *~
+ cd src && $(MAKE) clean
+- cd projects/demo && $(MAKE) clean
+-ifeq ($(REALTIME),yes)
+- cd projects/effects && $(MAKE) clean
+- cd projects/ragamatic && $(MAKE) clean
+- cd projects/eguitar && $(MAKE) clean
+-endif
+- cd projects/examples && $(MAKE) clean
+
+ distclean: clean
+ $(RM) -rf config.log config.status autom4te.cache Makefile
+ cd src && $(MAKE) distclean
+- cd projects/demo && $(MAKE) distclean
+-ifeq ($(REALTIME),yes)
+- cd projects/effects && $(MAKE) distclean
+- cd projects/ragamatic && $(MAKE) distclean
+- cd projects/eguitar && $(MAKE) distclean
+-endif
+- cd projects/examples && $(MAKE) distclean
+
+ install:
+ $(MAKE) -C src install
diff --git a/media-libs/stk/files/stk-4.5.1/050_all_cxxflags.patch b/media-libs/stk/files/stk-4.5.1/050_all_cxxflags.patch
new file mode 100644
index 000000000000..d2cc4e5be330
--- /dev/null
+++ b/media-libs/stk/files/stk-4.5.1/050_all_cxxflags.patch
@@ -0,0 +1,13 @@
+Index: stk-4.5.0/configure.ac
+===================================================================
+--- stk-4.5.0.orig/configure.ac
++++ stk-4.5.0/configure.ac
+@@ -100,7 +100,7 @@ fi
+ CPPFLAGS="$CPPFLAGS $cppflag"
+
+ # For debugging and optimization ... overwrite default because it has both -g and -O2
+-CXXFLAGS="$cxxflag"
++CXXFLAGS="$CXXFLAGS $cxxflag"
+
+ # Check compiler and use -Wall if gnu.
+ if [test $GXX = "yes" ;] then