summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-08-03 09:45:36 -0700
committerSam James <sam@gentoo.org>2022-10-14 01:23:07 +0100
commitdb80d3f5fa48ec73718e655fdad0fef85bcec942 (patch)
tree1516e674a06dd31b22461ad624c7eef561c545d7 /media-libs/tremor
parentapp-emulation/punes: Add 0.109 (diff)
downloadgentoo-db80d3f5fa48ec73718e655fdad0fef85bcec942.tar.gz
gentoo-db80d3f5fa48ec73718e655fdad0fef85bcec942.tar.bz2
gentoo-db80d3f5fa48ec73718e655fdad0fef85bcec942.zip
media-libs/tremor: Update pkgconfig to reduce overlinking
Upstream-Commit: https://gitlab.xiph.org/xiph/tremor/-/commit/a733870e048fc139f696f1c57b50e0145d1ab6c2 Upstream-Issue: https://gitlab.xiph.org/xiph/tremor/-/issues/1943 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/26727 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/tremor')
-rw-r--r--media-libs/tremor/files/tremor-0_pre20130223-pkgconfig.patch30
-rw-r--r--media-libs/tremor/tremor-0_pre20130223-r3.ebuild41
2 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/tremor/files/tremor-0_pre20130223-pkgconfig.patch b/media-libs/tremor/files/tremor-0_pre20130223-pkgconfig.patch
new file mode 100644
index 000000000000..e28e818de830
--- /dev/null
+++ b/media-libs/tremor/files/tremor-0_pre20130223-pkgconfig.patch
@@ -0,0 +1,30 @@
+Upstream-Commit: https://gitlab.xiph.org/xiph/tremor/-/commit/a733870e048fc139f696f1c57b50e0145d1ab6c2
+
+From a733870e048fc139f696f1c57b50e0145d1ab6c2 Mon Sep 17 00:00:00 2001
+From: Tim Terriberry <tterribe@xiph.org>
+Date: Fri, 5 Apr 2013 13:20:31 +0000
+Subject: [PATCH] Update pkgconfig files to reduce overlinking.
+
+Patch from Brad Smith.
+Reviewed by Ron Lee.
+Fixes #1943.
+
+git-svn-id: https://svn.xiph.org/trunk/Tremor@18906 0101bb08-14d6-0310-b084-bc0e0c8e3800
+---
+ vorbisidec.pc.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/vorbisidec.pc.in b/vorbisidec.pc.in
+index 9c09524..56fa656 100644
+--- a/vorbisidec.pc.in
++++ b/vorbisidec.pc.in
+@@ -8,7 +8,7 @@ includedir=@includedir@
+ Name: vorbisidec
+ Description: vorbisidec is the integer Ogg Vorbis library
+ Version: @VERSION@
+-Requires: ogg
++Requires.private: ogg
+ Conflicts:
+-Libs: -L${libdir} -lvorbisidec -lm
++Libs: -L${libdir} -lvorbisidec
+ Cflags: -I${includedir}
diff --git a/media-libs/tremor/tremor-0_pre20130223-r3.ebuild b/media-libs/tremor/tremor-0_pre20130223-r3.ebuild
new file mode 100644
index 000000000000..78b6fc640da1
--- /dev/null
+++ b/media-libs/tremor/tremor-0_pre20130223-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="A fixed-point version of the Ogg Vorbis decoder (also known as libvorbisidec)"
+HOMEPAGE="https://wiki.xiph.org/Tremor"
+SRC_URI="https://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
+IUSE="low-accuracy"
+
+RDEPEND=">=media-libs/libogg-1.3.0:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-out-of-bounds-write.patch
+ "${FILESDIR}"/${P}-autoconf.patch
+ "${FILESDIR}"/${P}-pkgconfig.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable low-accuracy)
+}
+
+multilib_src_install_all() {
+ HTML_DOCS=( doc/. )
+ einstalldocs
+
+ find "${ED}" -name '*.la' -type f -delete || die
+}