summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-02-10 19:45:48 +0100
committerNick Sarnie <sarnex@gentoo.org>2023-02-10 13:53:32 -0500
commit697296ffd1f3872c60bce4315b2a91454fe7638d (patch)
treeef8ac82acdc2852ae91afeb32a5d8b2270758c03 /media-libs/vulkan-layers/files
parentsys-process/systemd-cron: stabilize 1.15.19-r1 for amd64 (diff)
downloadgentoo-697296ffd1f3872c60bce4315b2a91454fe7638d.tar.gz
gentoo-697296ffd1f3872c60bce4315b2a91454fe7638d.tar.bz2
gentoo-697296ffd1f3872c60bce4315b2a91454fe7638d.zip
media-libs/vulkan-layers: remove unused patches
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/29534 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'media-libs/vulkan-layers/files')
-rw-r--r--media-libs/vulkan-layers/files/vulkan-layers-1.3.231-Make-BUILD_WERROR-actually-work.patch19
-rw-r--r--media-libs/vulkan-layers/files/vulkan-layers-1.3.231-cmake-Cleanup-find_package-SPIRV-code.patch101
2 files changed, 0 insertions, 120 deletions
diff --git a/media-libs/vulkan-layers/files/vulkan-layers-1.3.231-Make-BUILD_WERROR-actually-work.patch b/media-libs/vulkan-layers/files/vulkan-layers-1.3.231-Make-BUILD_WERROR-actually-work.patch
deleted file mode 100644
index 4bd9abf89a87..000000000000
--- a/media-libs/vulkan-layers/files/vulkan-layers-1.3.231-Make-BUILD_WERROR-actually-work.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e3985fc6d..ea8d47bb3 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -170,14 +170,6 @@ if(${CMAKE_C_COMPILER_ID} MATCHES "(GNU|Clang)")
- -fno-strict-aliasing
- -fno-builtin-memcmp)
-
-- # Treat warnings as errors for versions of GCC and c++11-compliant Clang versions that are shipped on Ubuntu 18.04 or older.
-- if(BUILD_WERROR OR
-- (${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS_EQUAL 7.3.0) OR
-- (${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang" AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 6.0.0))
-- add_compile_options(-Werror)
-- endif()
--
--
- set(CMAKE_C_STANDARD 99)
-
- # For GCC version 7.1 or greater, we need to disable the implicit fallthrough warning since there's no consistent way to satisfy
diff --git a/media-libs/vulkan-layers/files/vulkan-layers-1.3.231-cmake-Cleanup-find_package-SPIRV-code.patch b/media-libs/vulkan-layers/files/vulkan-layers-1.3.231-cmake-Cleanup-find_package-SPIRV-code.patch
deleted file mode 100644
index bd17c69315e0..000000000000
--- a/media-libs/vulkan-layers/files/vulkan-layers-1.3.231-cmake-Cleanup-find_package-SPIRV-code.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From 836a09267fe034ce783570e6920e1b638c0bd212 Mon Sep 17 00:00:00 2001
-From: Juan Ramos <juan@lunarg.com>
-Date: Fri, 21 Oct 2022 17:43:23 -0600
-Subject: [PATCH] cmake: Cleanup find_package SPIRV code
-
-- Use get_target_property instead of relying on passed in var
-- Remove unused var
-- Cleanup find_package(SPIRV-* code
----
- CMakeLists.txt | 55 +++++++++----------------------
- cmake/VVLGenerateSourceCode.cmake | 5 ++-
- 2 files changed, 19 insertions(+), 41 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a7f01081415..23de46a1a22 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -204,52 +204,27 @@ if (USE_ROBIN_HOOD_HASHING)
- endif()
-
- if(BUILD_LAYERS OR BUILD_TESTS)
-- find_package(SPIRV-Headers CONFIG QUIET)
-- if(SPIRV-Headers_FOUND)
-- # Prefer the package if found. Note that if SPIRV_HEADERS_INSTALL_DIR points at an 'installed'
-- # version of SPIRV-Headers, the package will be found.
-- get_target_property(SPIRV_HEADERS_INCLUDE_DIR SPIRV-Headers::SPIRV-Headers INTERFACE_INCLUDE_DIRECTORIES)
-- elseif(SPIRV_HEADERS_INCLUDE_DIR)
-- # This is set by SPIRV-Tools (in parent scope!) and also some packages that include VVL with add_subdirectory
-- if (NOT EXISTS "${SPIRV_HEADERS_INCLUDE_DIR}/spirv/unified1/spirv.h")
-- message(FATAL_ERROR "Cannot find SPIRV-Headers from SPIRV_HEADERS_INCLUDE_DIR: ${SPIRV_HEADERS_INCLUDE_DIR}")
-- endif()
-- elseif(SPIRV_HEADERS_INSTALL_DIR)
-- # This is our official variable for setting SPIRV-Headers location, but pointing at the raw source of SPIRV-Headers
-- if (NOT EXISTS "${SPIRV_HEADERS_INSTALL_DIR}/include/spirv/unified1/spirv.h")
-- message(FATAL_ERROR "Cannot find SPIRV-Headers from SPIRV_HEADERS_INSTALL_DIR: ${SPIRV_HEADERS_INSTALL_DIR}")
-- endif()
-- set(SPIRV_HEADERS_INCLUDE_DIR "${SPIRV_HEADERS_INSTALL_DIR}/include")
-- endif()
-+ find_package(SPIRV-Headers REQUIRED CONFIG QUIET)
-
-- # VVLGenerateSourceCode depends on spirv/unified1
- include(VVLGenerateSourceCode)
-
-- if (NOT TARGET SPIRV-Tools-opt)
-- find_package(SPIRV-Tools-opt REQUIRED CONFIG)
-- endif()
--
-- if (NOT TARGET SPIRV-Tools)
-- find_package(SPIRV-Tools REQUIRED CONFIG)
-- # See https://github.com/KhronosGroup/SPIRV-Tools/issues/3909 for background on this.
-- # The targets available from SPIRV-Tools change depending on how SPIRV_TOOLS_BUILD_STATIC is set.
-- # Try to handle all possible combinations so that we work with externally built packages.
-- if (TARGET SPIRV-Tools)
-- set(SPIRV_TOOLS_TARGET "SPIRV-Tools")
-- elseif(TARGET SPIRV-Tools-static)
-- set(SPIRV_TOOLS_TARGET "SPIRV-Tools-static")
-- elseif(TARGET SPIRV-Tools-shared)
-- set(SPIRV_TOOLS_TARGET "SPIRV-Tools-shared")
-- else()
-- message(FATAL_ERROR "Cannot determine SPIRV-Tools target name")
-- endif()
-+ find_package(SPIRV-Tools-opt REQUIRED CONFIG QUIET)
-+
-+ find_package(SPIRV-Tools REQUIRED CONFIG QUIET)
-+ # See https://github.com/KhronosGroup/SPIRV-Tools/issues/3909 for background on this.
-+ # The targets available from SPIRV-Tools change depending on how SPIRV_TOOLS_BUILD_STATIC is set.
-+ # Try to handle all possible combinations so that we work with externally built packages.
-+ if (TARGET SPIRV-Tools)
-+ set(SPIRV_TOOLS_TARGET "SPIRV-Tools")
-+ elseif(TARGET SPIRV-Tools-static)
-+ set(SPIRV_TOOLS_TARGET "SPIRV-Tools-static")
-+ elseif(TARGET SPIRV-Tools-shared)
-+ set(SPIRV_TOOLS_TARGET "SPIRV-Tools-shared")
-+ else()
-+ message(FATAL_ERROR "Cannot determine SPIRV-Tools target name")
- endif()
- endif()
-
--# Generate dependent helper files ------------------------------------------------------------------------------------------------
--
--set(SCRIPTS_DIR "${PROJECT_SOURCE_DIR}/scripts")
--
- # VkLayer_utils library ----------------------------------------------------------------------------------------------------------
- # For Windows, we use a static lib because the Windows loader has a fairly restrictive loader search path that can't be easily
- # modified to point it to the same directory that contains the layers. TODO: This should not be a library -- in future, include
-diff --git a/cmake/VVLGenerateSourceCode.cmake b/cmake/VVLGenerateSourceCode.cmake
-index 43efdb8201c..13c81e38aca 100644
---- a/cmake/VVLGenerateSourceCode.cmake
-+++ b/cmake/VVLGenerateSourceCode.cmake
-@@ -20,7 +20,10 @@ if(PYTHONINTERP_FOUND)
- message(FATAL_ERROR "Unable to find vk.xml")
- endif()
-
-- set(spirv_unified_include_dir "${SPIRV_HEADERS_INSTALL_DIR}/include/spirv/unified1/")
-+ # Get the include directory of the SPIRV-Headers
-+ get_target_property(SPIRV_HEADERS_INCLUDE_DIR SPIRV-Headers::SPIRV-Headers INTERFACE_INCLUDE_DIRECTORIES)
-+
-+ set(spirv_unified_include_dir "${SPIRV_HEADERS_INCLUDE_DIR}/spirv/unified1/")
- if (NOT IS_DIRECTORY ${spirv_unified_include_dir})
- message(FATAL_ERROR "Unable to find spirv/unified1")
- endif()