summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-20 09:27:14 +0000
committerSam James <sam@gentoo.org>2023-12-20 10:03:27 +0000
commit45e5260fd5566ea0c1cf8fa3191f0507ddeacc66 (patch)
tree42ed5cd0221ff89eae53c3672cff5f6318c9317d /media-libs
parentnet-analyzer/traceroute: add 2.1.5 (diff)
downloadgentoo-45e5260fd5566ea0c1cf8fa3191f0507ddeacc66.tar.gz
gentoo-45e5260fd5566ea0c1cf8fa3191f0507ddeacc66.tar.bz2
gentoo-45e5260fd5566ea0c1cf8fa3191f0507ddeacc66.zip
media-libs/libraw: add 0.21.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libraw/Manifest1
-rw-r--r--media-libs/libraw/libraw-0.21.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/libraw/Manifest b/media-libs/libraw/Manifest
index 2e70f1636db2..13e188720640 100644
--- a/media-libs/libraw/Manifest
+++ b/media-libs/libraw/Manifest
@@ -1 +1,2 @@
DIST LibRaw-0.21.1.tar.gz 1638461 BLAKE2B 5db9a02f6854b90acf5e22419e2bc5470118140173be38cb520cc03553a328cad86d97ebda62c149622e045325ce82dcc34df40b5f700c319929c10fc43fdc9e SHA512 8d11df0be2af5fd8a8251f150ccd59103319606f52effff541ee43e97ceb64f1a00a02bba7b730aedd0c1c705c1e465793c8a2a52769712c1102af7f5534dd5d
+DIST LibRaw-0.21.2.tar.gz 1639305 BLAKE2B 8ff6cbc205335bdf12bfdfb77e390cf45f6e7a3dfcc0e6cc5ea759ac3a7b11d9f8a89c19218f779951dd8b1d96c779cb1d502c4691ee11cdccd83c27f09c6bf8 SHA512 ba7839d8eb5f999982c7b89f89f63387d7fee82054d7edcc2698924e268559b561230e329a0c669bd6f7c075983da6c054a6d63fad49ab3c1e2e9edc653b2bae
diff --git a/media-libs/libraw/libraw-0.21.2.ebuild b/media-libs/libraw/libraw-0.21.2.ebuild
new file mode 100644
index 000000000000..f68f9f0c11b0
--- /dev/null
+++ b/media-libs/libraw/libraw-0.21.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal toolchain-funcs
+
+MY_PN=LibRaw
+MY_PV="${PV/_b/-B}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
+HOMEPAGE="https://www.libraw.org/ https://github.com/LibRaw/LibRaw"
+SRC_URI="https://www.libraw.org/data/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 CDDL"
+# SONAME isn't exactly the same as PV but it does correspond and
+# libraw has unstable ABI across releases.
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples jpeg +lcms openmp zlib"
+
+RDEPEND="
+ jpeg? ( media-libs/libjpeg-turbo:=[${MULTILIB_USEDEP}] )
+ lcms? ( >=media-libs/lcms-2.5:2[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( Changelog.txt README.md )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-jasper
+ $(multilib_native_use_enable examples)
+ $(use_enable jpeg)
+ $(use_enable lcms)
+ $(use_enable openmp)
+ $(use_enable zlib)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package installs .pc files
+ find "${D}" -name '*.la' -delete || die
+}