summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-12 04:42:05 +0100
committerSam James <sam@gentoo.org>2024-06-12 04:48:03 +0100
commit4df7f4ac02f210c93c4f2d94fcd30b34f33ddc2d (patch)
treef96663344c4442ec16b4ec752db8a716130de895 /media-libs
parentdev-python/pyalsa: add 1.2.12 (diff)
downloadgentoo-4df7f4ac02f210c93c4f2d94fcd30b34f33ddc2d.tar.gz
gentoo-4df7f4ac02f210c93c4f2d94fcd30b34f33ddc2d.tar.bz2
gentoo-4df7f4ac02f210c93c4f2d94fcd30b34f33ddc2d.zip
media-libs/alsa-lib: add 1.2.12
Closes: https://bugs.gentoo.org/914511 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/Manifest1
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.2.12.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
index e85cb3c13e59..d3ddaa9f97a8 100644
--- a/media-libs/alsa-lib/Manifest
+++ b/media-libs/alsa-lib/Manifest
@@ -1,2 +1,3 @@
DIST alsa-lib-1.2.10.tar.bz2 1107007 BLAKE2B b2e4f8431e61f5bb56b2b5d124e67d5a68bbca3c647bebfa93f5e5ff092ec9ef3f6cb6315801fcd93e21151784814ff238d357313b8b44f32d4e7c9ee565388f SHA512 4ccbd1dc5a612044571c26290923009e4c3f7959b30a5d0bed47daa68bbefaff9059c4f0fa3bc16f22c1eed2d36f079139369f40243da5921ae4de02a4541939
DIST alsa-lib-1.2.11.tar.bz2 1107150 BLAKE2B 7fb245ffbfb841bdd5cb9da08fb2ec0a4ce8d340d4d1461999aca558c67c16e7c596cd0bffab761b7b4549025b0fb25462fb352e6d3900fb42f00b47de58d34c SHA512 7bf2c541dff5262c0302a1c716ca10cdb5105f4e0ad48f3341c3c7e975b0c3ea835a298a05974c3e216a85912c368d8025ba3cdda3ff04a7683133ce5b2a286d
+DIST alsa-lib-1.2.12.tar.bz2 1108712 BLAKE2B bcb48ad2c8687454b312e789c650136fee0db8cccf58e997b9d619aac5c74288b69220589efdcd3917eb1d781ef71be5fcd16d997c59c069fe20788d1a479068 SHA512 053e36e51c0ff28f07028b89c8845b50682a5c14035ab85c2fc8cae2f2f0d05e4cd45ed879602c15c1596fb7fe84bfd50ec0d119dfb55c66589a2d458a9b317d
diff --git a/media-libs/alsa-lib/alsa-lib-1.2.12.ebuild b/media-libs/alsa-lib/alsa-lib-1.2.12.ebuild
new file mode 100644
index 000000000000..29238ca3c274
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.2.12.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit autotools multilib-minimal flag-o-matic python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
+if [[ ${PV} == *_p* ]] ; then
+ # Please set correct commit ID for a snapshot release!
+ COMMIT="7e3a3c2b0a092d0f568ba3c98365030dd91cc877"
+ SRC_URI="https://git.alsa-project.org/?p=${PN}.git;a=snapshot;h=${COMMIT};sf=tgz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT:0:7}
+else
+ # TODO: Upstream does publish .sig files, so someone could implement verify-sig ;)
+ SRC_URI="https://www.alsa-project.org/files/pub/lib/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ media-libs/alsa-topology-conf
+ media-libs/alsa-ucm-conf
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( >=app-text/doxygen-1.2.6 )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.6-missing_files.patch" # bug #652422
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # bug #545950
+ sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # Broken upstream. Could in theory work with -flto-partitions=none
+ # but it's a hack to workaround the real problem and not strictly safe.
+ # bug #616108, bug #669086, and https://github.com/alsa-project/alsa-lib/issues/6.
+ # (This bug is closed as of 1.2.9 but there's been no clear actual fix to it.
+ # Let us know if you can identify one.)
+ filter-lto
+
+ local myeconfargs=(
+ --disable-maintainer-mode
+ --disable-resmgr
+ --enable-aload
+ --enable-rawmidi
+ --enable-seq
+ --enable-shared
+ --enable-thread-safety
+
+ $(multilib_native_use_enable python)
+ $(use_enable alisp)
+ $(use_with debug)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ grep -FZrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::" || die
+ fi
+}
+
+multilib_src_install() {
+ multilib_is_native_abi && use doc && local HTML_DOCS=( doc/doxygen/html/. )
+
+ default
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}