summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-06-06 11:03:37 +0300
committerSam James <sam@gentoo.org>2021-06-09 21:33:57 +0000
commit9933f6370e9e1af96dad6f922449da5988e2a576 (patch)
treeece491e4c77a3172571b8213d5eeac2812ad2d64 /media-libs
parentmedia-libs/gegl: fix USE="openexr" build against >=dev-libs/glib-2.67.3 (diff)
downloadgentoo-9933f6370e9e1af96dad6f922449da5988e2a576.tar.gz
gentoo-9933f6370e9e1af96dad6f922449da5988e2a576.tar.bz2
gentoo-9933f6370e9e1af96dad6f922449da5988e2a576.zip
media-libs/gegl: fix USE="openexr" build against media-libs/openexr-3.0.1
Closes: https://bugs.gentoo.org/788400 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/21135 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gegl/files/gegl-0.4.30-fix-build-openexr-3.patch22
-rw-r--r--media-libs/gegl/gegl-0.4.26-r1.ebuild1
-rw-r--r--media-libs/gegl/gegl-0.4.28.ebuild1
-rw-r--r--media-libs/gegl/gegl-0.4.30.ebuild4
4 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/gegl/files/gegl-0.4.30-fix-build-openexr-3.patch b/media-libs/gegl/files/gegl-0.4.30-fix-build-openexr-3.patch
new file mode 100644
index 000000000000..e0e938acc22e
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.4.30-fix-build-openexr-3.patch
@@ -0,0 +1,22 @@
+From 499a239d158fadb3a04499255b5b282a8a6023bb Mon Sep 17 00:00:00 2001
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Sat, 24 Apr 2021 10:51:09 +0000
+Subject: [PATCH] Fix build with OpenEXR 3
+
+Add a header that is no longer transitively included
+---
+ operations/external/exr-save.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/operations/external/exr-save.cc b/operations/external/exr-save.cc
+index 1e8c09d96..87abed511 100644
+--- a/operations/external/exr-save.cc
++++ b/operations/external/exr-save.cc
+@@ -45,6 +45,7 @@ extern "C" {
+ #include <ImfChromaticities.h>
+ #include <ImfStandardAttributes.h>
+ #include <ImfArray.h>
++#include <ImfFrameBuffer.h>
+ #include "ImathRandom.h"
+
+
diff --git a/media-libs/gegl/gegl-0.4.26-r1.ebuild b/media-libs/gegl/gegl-0.4.26-r1.ebuild
index bc7777e314bb..71107e34e87e 100644
--- a/media-libs/gegl/gegl-0.4.26-r1.ebuild
+++ b/media-libs/gegl/gegl-0.4.26-r1.ebuild
@@ -79,6 +79,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.4.18-drop-failing-tests.patch
"${FILESDIR}"/${PN}-0.4.18-program-suffix.patch
"${FILESDIR}"/${P}-fix-build-glib-2.67.3.patch
+ "${FILESDIR}"/${PN}-0.4.30-fix-build-openexr-3.patch
)
python_check_deps() {
diff --git a/media-libs/gegl/gegl-0.4.28.ebuild b/media-libs/gegl/gegl-0.4.28.ebuild
index ba46251dad91..db9f50a4fb71 100644
--- a/media-libs/gegl/gegl-0.4.28.ebuild
+++ b/media-libs/gegl/gegl-0.4.28.ebuild
@@ -79,6 +79,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.4.18-drop-failing-tests.patch
"${FILESDIR}"/${PN}-0.4.18-program-suffix.patch
"${FILESDIR}"/${PN}-0.4.26-fix-build-glib-2.67.3.patch
+ "${FILESDIR}"/${PN}-0.4.30-fix-build-openexr-3.patch
)
python_check_deps() {
diff --git a/media-libs/gegl/gegl-0.4.30.ebuild b/media-libs/gegl/gegl-0.4.30.ebuild
index 62fe72b1c9a4..0f6d0b738252 100644
--- a/media-libs/gegl/gegl-0.4.30.ebuild
+++ b/media-libs/gegl/gegl-0.4.30.ebuild
@@ -75,6 +75,10 @@ BDEPEND="
DOCS=( AUTHORS docs/ChangeLog docs/NEWS.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-openexr-3.patch
+)
+
python_check_deps() {
use test || return 0
has_version -b ">=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}]"