summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-01 20:34:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-01 22:21:37 -0400
commita319623fa3d2866776b84a6a95933152078a68fb (patch)
treed5ab673d26c9a25e049bfd84b30038a643ce5d28 /media-libs
parentmedia-libs/smpeg2: EAPI8 bump, ebuild improvements (diff)
downloadgentoo-a319623fa3d2866776b84a6a95933152078a68fb.tar.gz
gentoo-a319623fa3d2866776b84a6a95933152078a68fb.tar.bz2
gentoo-a319623fa3d2866776b84a6a95933152078a68fb.zip
media-libs/smpeg: drop X+debug IUSE, adjust libsdl dep
X is not used, doesn't link with any of the libraries, doesn't include headers, and it doesn't change any code paths if disabled. debug was only used to control -DNDEBUG Add libsdl[opengl?,sound,video] needed by plaympeg/glmovie, albeit it may have been better to simply not build/support these like smpeg2. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/smpeg/smpeg-0.4.4-r11.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/media-libs/smpeg/smpeg-0.4.4-r11.ebuild b/media-libs/smpeg/smpeg-0.4.4-r11.ebuild
index 6c94b2006f77..e79dae9392a0 100644
--- a/media-libs/smpeg/smpeg-0.4.4-r11.ebuild
+++ b/media-libs/smpeg/smpeg-0.4.4-r11.ebuild
@@ -13,18 +13,13 @@ SRC_URI="https://mirrors.dotsrc.org/lokigames/open-source/smpeg/${P}.tar.gz
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="X debug cpu_flags_x86_mmx opengl"
+IUSE="cpu_flags_x86_mmx opengl"
RDEPEND="
- media-libs/libsdl[${MULTILIB_USEDEP}]
+ media-libs/libsdl[opengl?,sound,video,${MULTILIB_USEDEP}]
opengl? (
virtual/glu[${MULTILIB_USEDEP}]
virtual/opengl[${MULTILIB_USEDEP}]
- )
- X? (
- x11-libs/libXext[${MULTILIB_USEDEP}]
- x11-libs/libXi[${MULTILIB_USEDEP}]
- x11-libs/libX11[${MULTILIB_USEDEP}]
)"
DEPEND="${RDEPEND}"
@@ -57,10 +52,9 @@ multilib_src_configure() {
local myeconfargs=(
--disable-gtk-player
--enable-debug # disabling this only passes extra optimizations
+ --without-x # does not actually use X, only causes a headers check
$(use_enable cpu_flags_x86_mmx mmx)
- $(use_enable debug assertions)
$(use_enable opengl opengl-player)
- $(use_with X x)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}