summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-28 17:30:22 -0500
committerSam James <sam@gentoo.org>2024-02-28 22:57:01 +0000
commitaec66421746a0ac2dc2b2eebed6e0f0d2abe3405 (patch)
treed10536f147e9b4110c41ddd16936dc3b216d19ac /media-libs
parentdev-python/shiboken6: mark as LTO-unsafe (diff)
downloadgentoo-aec66421746a0ac2dc2b2eebed6e0f0d2abe3405.tar.gz
gentoo-aec66421746a0ac2dc2b2eebed6e0f0d2abe3405.tar.bz2
gentoo-aec66421746a0ac2dc2b2eebed6e0f0d2abe3405.zip
media-libs/plib: mark LTO-unsafe, mark strict-aliasing unsafe
This code is formally terrible. It is so terrible, because upstream claims: "PLIB has been obsolete and unmaintained for at LEAST 15 years!!" https://sourceforge.net/p/plib/bugs/55/#88e9 And that was already 3 years ago. We can't fix it so limit the extent to which compilers are allowed to misinterpret it. Closes: https://bugs.gentoo.org/860048 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/plib/plib-1.8.5-r4.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-libs/plib/plib-1.8.5-r4.ebuild b/media-libs/plib/plib-1.8.5-r4.ebuild
index 3e4494514020..b5769bd1ab11 100644
--- a/media-libs/plib/plib-1.8.5-r4.ebuild
+++ b/media-libs/plib/plib-1.8.5-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,6 +32,12 @@ src_prepare() {
src_configure() {
append-cxxflags -std=c++03
+ # violates strict aliasing rules and is LTO-unsafe: https://bugs.gentoo.org/860048
+ # Per upstream in 2021, "PLIB has been obsolete and unmaintained for at LEAST 15 years!!"
+ # so this is getting fixed exactly never and getting worse.
+ append-cxxflags -fno-strict-aliasing
+ filter-lto
+
local myconf=(
--enable-shared
)