summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-05-13 16:56:10 +1000
committerJoonas Niilola <juippis@gentoo.org>2020-06-08 10:45:20 +0300
commitde16806017d00dbe9faaa203d086ce3b29b95919 (patch)
treec02911a55ed7edbc08a525af287ddfeae92bebf6 /media-libs
parentmedia-libs/opensubdiv: Version bump to 3.4.3 (diff)
downloadgentoo-de16806017d00dbe9faaa203d086ce3b29b95919.tar.gz
gentoo-de16806017d00dbe9faaa203d086ce3b29b95919.tar.bz2
gentoo-de16806017d00dbe9faaa203d086ce3b29b95919.zip
media-libs/opensubdiv: Update to EAPI 7
Update ebuild to use EAPI 7. Remove eapi7-ver from inherit. Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.3.3-install-tutorials-into-bin.patch130
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.3.3.ebuild70
2 files changed, 178 insertions, 22 deletions
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.3.3-install-tutorials-into-bin.patch b/media-libs/opensubdiv/files/opensubdiv-3.3.3-install-tutorials-into-bin.patch
new file mode 100644
index 000000000000..ec63f47b4404
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.3.3-install-tutorials-into-bin.patch
@@ -0,0 +1,130 @@
+diff -Naur a/tutorials/far/tutorial_0/CMakeLists.txt b/tutorials/far/tutorial_0/CMakeLists.txt
+--- a/tutorials/far/tutorial_0/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/far/tutorial_0/CMakeLists.txt 2020-05-13 16:06:40.857855388 +1000
+@@ -33,5 +33,5 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+-install(TARGETS far_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS far_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/far/tutorial_1/CMakeLists.txt b/tutorials/far/tutorial_1/CMakeLists.txt
+--- a/tutorials/far/tutorial_1/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/far/tutorial_1/CMakeLists.txt 2020-05-13 16:06:53.137874901 +1000
+@@ -33,5 +33,5 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+-install(TARGETS far_tutorial_1 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS far_tutorial_1 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/far/tutorial_2/CMakeLists.txt b/tutorials/far/tutorial_2/CMakeLists.txt
+--- a/tutorials/far/tutorial_2/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/far/tutorial_2/CMakeLists.txt 2020-05-13 16:07:04.297892363 +1000
+@@ -33,5 +33,5 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+-install(TARGETS far_tutorial_2 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS far_tutorial_2 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/far/tutorial_3/CMakeLists.txt b/tutorials/far/tutorial_3/CMakeLists.txt
+--- a/tutorials/far/tutorial_3/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/far/tutorial_3/CMakeLists.txt 2020-05-13 16:07:20.377917078 +1000
+@@ -33,5 +33,5 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+-install(TARGETS far_tutorial_3 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS far_tutorial_3 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/far/tutorial_4/CMakeLists.txt b/tutorials/far/tutorial_4/CMakeLists.txt
+--- a/tutorials/far/tutorial_4/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/far/tutorial_4/CMakeLists.txt 2020-05-13 16:07:36.727941691 +1000
+@@ -33,5 +33,5 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+-install(TARGETS far_tutorial_4 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS far_tutorial_4 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/far/tutorial_5/CMakeLists.txt b/tutorials/far/tutorial_5/CMakeLists.txt
+--- a/tutorials/far/tutorial_5/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/far/tutorial_5/CMakeLists.txt 2020-05-13 16:07:44.797953646 +1000
+@@ -33,5 +33,5 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+-install(TARGETS far_tutorial_5 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS far_tutorial_5 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/far/tutorial_6/CMakeLists.txt b/tutorials/far/tutorial_6/CMakeLists.txt
+--- a/tutorials/far/tutorial_6/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/far/tutorial_6/CMakeLists.txt 2020-05-13 16:07:53.847966914 +1000
+@@ -33,5 +33,5 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+-install(TARGETS far_tutorial_6 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS far_tutorial_6 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/far/tutorial_7/CMakeLists.txt b/tutorials/far/tutorial_7/CMakeLists.txt
+--- a/tutorials/far/tutorial_7/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/far/tutorial_7/CMakeLists.txt 2020-05-13 16:08:02.047978804 +1000
+@@ -33,5 +33,5 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+-install(TARGETS far_tutorial_7 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS far_tutorial_7 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/far/tutorial_8/CMakeLists.txt b/tutorials/far/tutorial_8/CMakeLists.txt
+--- a/tutorials/far/tutorial_8/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/far/tutorial_8/CMakeLists.txt 2020-05-13 16:08:16.287999162 +1000
+@@ -33,5 +33,5 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+-install(TARGETS far_tutorial_8 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS far_tutorial_8 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/hbr/tutorial_0/CMakeLists.txt b/tutorials/hbr/tutorial_0/CMakeLists.txt
+--- a/tutorials/hbr/tutorial_0/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/hbr/tutorial_0/CMakeLists.txt 2020-05-13 16:08:37.278028518 +1000
+@@ -30,5 +30,5 @@
+ ${SOURCE_FILES}
+ )
+
+-install(TARGETS hbr_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS hbr_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/hbr/tutorial_1/CMakeLists.txt b/tutorials/hbr/tutorial_1/CMakeLists.txt
+--- a/tutorials/hbr/tutorial_1/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/hbr/tutorial_1/CMakeLists.txt 2020-05-13 16:08:45.028039168 +1000
+@@ -30,5 +30,5 @@
+ ${SOURCE_FILES}
+ )
+
+-install(TARGETS hbr_tutorial_1 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS hbr_tutorial_1 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/hbr/tutorial_2/CMakeLists.txt b/tutorials/hbr/tutorial_2/CMakeLists.txt
+--- a/tutorials/hbr/tutorial_2/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/hbr/tutorial_2/CMakeLists.txt 2020-05-13 16:08:54.138051562 +1000
+@@ -30,5 +30,5 @@
+ ${SOURCE_FILES}
+ )
+
+-install(TARGETS hbr_tutorial_2 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS hbr_tutorial_2 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/osd/tutorial_0/CMakeLists.txt b/tutorials/osd/tutorial_0/CMakeLists.txt
+--- a/tutorials/osd/tutorial_0/CMakeLists.txt 2020-05-13 16:06:02.537792402 +1000
++++ b/tutorials/osd/tutorial_0/CMakeLists.txt 2020-05-13 16:09:10.748073802 +1000
+@@ -35,5 +35,5 @@
+ osd_static_cpu
+ )
+
+-install(TARGETS osd_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS osd_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}")
+
diff --git a/media-libs/opensubdiv/opensubdiv-3.3.3.ebuild b/media-libs/opensubdiv/opensubdiv-3.3.3.ebuild
index eedadea99852..c0ddde3439a5 100644
--- a/media-libs/opensubdiv/opensubdiv-3.3.3.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.3.3.ebuild
@@ -1,42 +1,63 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils toolchain-funcs eapi7-ver
+CMAKE_MAKEFILE_GENERATOR=emake
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake python-utils-r1 toolchain-funcs
MY_PV="$(ver_rs "1-3" '_')"
DESCRIPTION="An Open-Source subdivision surface library"
-HOMEPAGE="http://graphics.pixar.com/opensubdiv/"
+HOMEPAGE="https://graphics.pixar.com/opensubdiv/docs/intro.html"
SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="ZLIB"
+# Modfied Apache-2.0 license, where section 6 has been replaced.
+# See for example CMakeLists.txt for details.
+LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE="cuda doc opencl openmp ptex tbb"
+IUSE="cuda doc examples opencl openmp ptex tbb test tutorials"
-RDEPEND="media-libs/glew:=
+RDEPEND="
+ ${PYTHON_DEPENDS}
+ media-libs/glew:=
media-libs/glfw:=
cuda? ( dev-util/nvidia-cuda-toolkit:* )
opencl? ( virtual/opencl )
- ptex? ( media-libs/ptex )"
-
-DEPEND="${RDEPEND}
+ ptex? ( media-libs/ptex )
+ x11-libs/libXinerama
+"
+DEPEND="
+ ${RDEPEND}
+ tbb? ( dev-cpp/tbb )
+"
+BDEPEND="
doc? (
dev-python/docutils
app-doc/doxygen
)
- tbb? ( dev-cpp/tbb )"
+ cuda? ( <sys-devel/gcc-9[cxx] )
+"
S="${WORKDIR}/OpenSubdiv-${MY_PV}"
PATCHES=(
- "${FILESDIR}/${PN}-3.3.0-fix-quotes.patch"
"${FILESDIR}/${PN}-3.3.0-use-gnuinstalldirs.patch"
"${FILESDIR}/${PN}-3.3.0-add-CUDA9-compatibility.patch"
+ "${FILESDIR}/${PN}-3.4.0-0001-documentation-CMakeLists.txt-force-python2.patch"
+ "${FILESDIR}/${P}-install-tutorials-into-bin.patch"
)
+RESTRICT="!test? ( test )"
+
pkg_pretend() {
+ if use cuda; then
+ [[ $(gcc-major-version) -gt 8 ]] && \
+ eerror "USE=cuda requires gcc < 9. Run gcc-config to switch your default compiler" && \
+ die "Need gcc version earlier than 9"
+ fi
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
@@ -45,20 +66,25 @@ pkg_setup() {
}
src_configure() {
+ # GLTESTS are disabled as portage is unable to open a display during test phase
local mycmakeargs=(
- -DNO_CLEW=1
+ -DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
+ -DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
+ -DNO_CLEW=ON
+ -DNO_CUDA=$(usex !cuda)
-DNO_DOC=$(usex !doc)
- -DNO_TBB=$(usex !tbb)
- -DNO_PTEX=$(usex !ptex)
+ -DNO_EXAMPLES=$(usex !examples)
+ -DNO_GLTESTS=ON
-DNO_OMP=$(usex !openmp)
-DNO_OPENCL=$(usex !opencl)
- -DNO_CUDA=$(usex !cuda)
- -DNO_REGRESSION=1 # They don't work with certain settings
- -DNO_EXAMPLES=1 # Not needed.
- -DNO_TUTORIALS=1 # They install illegally. Need to find a better solution.
- -DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
- -DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
+ -DNO_PTEX=$(usex !ptex)
+ -DNO_REGRESSION=$(usex !test)
+ -DNO_TBB=$(usex !tbb)
+ -DNO_TESTS=$(usex !test)
+ -DNO_TUTORIALS=$(usex !tutorials)
)
- cmake-utils_src_configure
+ # fails with building cuda kernels when using multiple jobs
+ export MAKEOPTS="-j1"
+ cmake_src_configure
}