summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/amb-plugins/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/amb-plugins/files')
-rw-r--r--media-plugins/amb-plugins/files/amb-plugins-0.8.1-Makefile.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/amb-plugins/files/amb-plugins-0.8.1-Makefile.patch b/media-plugins/amb-plugins/files/amb-plugins-0.8.1-Makefile.patch
new file mode 100644
index 000000000000..5cc183408c70
--- /dev/null
+++ b/media-plugins/amb-plugins/files/amb-plugins-0.8.1-Makefile.patch
@@ -0,0 +1,43 @@
+--- AMB-plugins-0.8.1/Makefile.old 2010-12-28 02:37:00.828999995 +0000
++++ AMB-plugins-0.8.1/Makefile 2010-12-28 02:39:14.333999996 +0000
+@@ -15,35 +15,35 @@
+ # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+
+-CPPFLAGS += -I. -fPIC -D_REENTRANT -Wall -O3
++CPPFLAGS += -I. -fPIC -D_REENTRANT -Wall
+
+
+ all: ambisonic0.so ambisonic1.so ambisonic2.so ambisonic3.so
+
+
+ ambisonic0.so: ambisonic0.o ambisonic0_if.o virtmic.o allpass.o
+- g++ -shared -o $@ ambisonic0.o ambisonic0_if.o virtmic.o allpass.o
++ $(CXX) $(LDFLAGS) -shared -o $@ ambisonic0.o ambisonic0_if.o virtmic.o allpass.o
+
+ ambisonic0.o: ladspaplugin.h ambisonic0.h
+ ambisonic0_if.o: ladspaplugin.h ambisonic0.h
+
+
+ ambisonic1.so: ambisonic1.o ambisonic1_if.o filter1.o
+- g++ -shared -o $@ ambisonic1.o ambisonic1_if.o filter1.o
++ $(CXX) $(LDFLAGS) -shared -o $@ ambisonic1.o ambisonic1_if.o filter1.o
+
+ ambisonic1.o: ladspaplugin.h ambisonic1.h filter1.h
+ ambisonic1_if.o: ladspaplugin.h ambisonic1.h
+
+
+ ambisonic2.so: ambisonic2.o ambisonic2_if.o
+- g++ -shared -o $@ ambisonic2.o ambisonic2_if.o
++ $(CXX) $(LDFLAGS) -shared -o $@ ambisonic2.o ambisonic2_if.o
+
+ ambisonic2.o: ladspaplugin.h ambisonic2.h
+ ambisonic2_if.o: ladspaplugin.h ambisonic2.h
+
+
+ ambisonic3.so: ambisonic3.o ambisonic3_if.o
+- g++ -shared -o $@ ambisonic3.o ambisonic3_if.o
++ $(CXX) $(LDFLAGS) -shared -o $@ ambisonic3.o ambisonic3_if.o
+
+ ambisonic3.o: ladspaplugin.h ambisonic3.h
+ ambisonic3_if.o: ladspaplugin.h ambisonic3.h