summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-05 12:49:02 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-05 12:49:02 +0100
commitbeae50663486be82a96836334c9e45d1b4416d40 (patch)
tree36f6264d10bebad3a127b94670fa26e387d75fd9 /media-plugins/audacious-plugins
parentmedia-sound/audacious: Version bump to 3.9 (diff)
downloadgentoo-beae50663486be82a96836334c9e45d1b4416d40.tar.gz
gentoo-beae50663486be82a96836334c9e45d1b4416d40.tar.bz2
gentoo-beae50663486be82a96836334c9e45d1b4416d40.zip
media-plugins/audacious-plugins: Version bump to 3.9
Closes: https://bugs.gentoo.org/564466 Closes: https://bugs.gentoo.org/572334 Closes: https://bugs.gentoo.org/572796 Closes: https://bugs.gentoo.org/573886 Closes: https://bugs.gentoo.org/573888 Closes: https://bugs.gentoo.org/590008 Closes: https://bugs.gentoo.org/611106 Closes: https://bugs.gentoo.org/636318 Closes: https://bugs.gentoo.org/636320 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'media-plugins/audacious-plugins')
-rw-r--r--media-plugins/audacious-plugins/Manifest1
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-3.9.ebuild164
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-9999.ebuild164
-rw-r--r--media-plugins/audacious-plugins/metadata.xml46
4 files changed, 353 insertions, 22 deletions
diff --git a/media-plugins/audacious-plugins/Manifest b/media-plugins/audacious-plugins/Manifest
index f02008cc184b..6f5c13511057 100644
--- a/media-plugins/audacious-plugins/Manifest
+++ b/media-plugins/audacious-plugins/Manifest
@@ -5,3 +5,4 @@ DIST audacious-plugins-3.7.1-gtk3.tar.bz2 1838067 SHA256 75469b52694fcfce237a937
DIST audacious-plugins-3.7.1.tar.bz2 1838045 SHA256 228a384f26afb000099166776d3454539956aa00fde90dcb4612ce8910ed4116 SHA512 2d22131babba572af235ec5f27135061a1602be55a2f709e327b7cd4052f7c11bc31398d01574a6f07197daa6b79cb42d5fa7b26f75764680420a46aede5cd9a WHIRLPOOL 026c355c6323aa6b56b09c119d9320ec5a7306f11b90504631f8a25c05b4f9bd1641ff223e0122a7b5be48f341a3820b759d1829ca60274285cfe19897c9edae
DIST audacious-plugins-3.8.2-gtk3.tar.bz2 1821924 SHA256 7849024beae61b8af3874b166cf3977905aec77859e53901158b531b31ef0cef SHA512 a5457cecc72ca4d57a3fad686b5ff42b2110d8ef65203fa49ad063c8944fc41af5d231b0870126e21c4cc8b3152de36c13726813075d26ba86450ef2132a6d33 WHIRLPOOL 0a75dd8a439dd30dce4764385fa60f317c521c3f45b5e4ae6c1d14f6a677774854d4c1650ba59facc7d204cbd53b7a8b3fca8dd94ee1b040fc2c8f444b179e4f
DIST audacious-plugins-3.8.2.tar.bz2 1821558 SHA256 d7cefca7a0e32bf4e58bb6e84df157268b5e9a6771a0e8c2da98b03f92a5fdd4 SHA512 61be2ee962853ed05366d4089ae1bef96c282ff61a947dc32f06651a9b620035a33cf4d75f4c4d74821099f36f9124f2b2266940f4844d14ca43ef70a81cde08 WHIRLPOOL 9d87947da3a7d90f0e5262d27dcbbbff2cfc833d340e87448a11d7c5fdfd5a64d8e1f49823a50e7f6ff33214a93594051e561e75eab422aa6321402067076e75
+DIST audacious-plugins-3.9.tar.bz2 1843084 SHA256 8bf7f21089cb3406968cc9c71307774aee7100ec4607f28f63cf5690d5c927b8 SHA512 00c8c53d69995ca1fedb91c7df609cc6c65b13e1af23b98a2fbda143c02ac554cc2c42c01f1c593af252e36bfb85b6324f2daca8632d3b672c69fb4dead2e3fa WHIRLPOOL e0b7cb6a6fb97d7cd69be4d2efc7867bb8510e6ea94af84055e3c61ffb8b06e716f7ac30b961155d560f4e646b82c7df894a7024cfe68c0ee47c64b9e66e9665
diff --git a/media-plugins/audacious-plugins/audacious-plugins-3.9.ebuild b/media-plugins/audacious-plugins/audacious-plugins-3.9.ebuild
new file mode 100644
index 000000000000..2b9250e27221
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-3.9.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/audacious-media-player/audacious-plugins.git"
+else
+ SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="aac +adplug alsa ampache aosd bs2b cdda cue ffmpeg flac fluidsynth gnome hotkeys http gme gtk jack lame libav
+ libnotify libsamplerate lirc mms modplug mp3 nls pulseaudio qt5 scrobbler sdl sid sndfile soxr vorbis wavpack"
+REQUIRED_USE="
+ ^^ ( gtk qt5 )
+ qt5? ( !libnotify )
+ || ( alsa jack pulseaudio sdl )"
+
+# The following plugins REQUIRE a GUI build of audacious, because non-GUI
+# builds do NOT install the libaudgui library & headers.
+# Plugins without a configure option:
+# alarm
+# albumart
+# delete-files
+# ladspa
+# playlist-manager
+# search-tool
+# skins
+# vtx
+# Plugins with a configure option:
+# glspectrum
+# gtkui
+# hotkey
+# notify
+# statusicon
+RDEPEND="
+ app-arch/unzip
+ dev-libs/dbus-glib
+ dev-libs/glib[utils]
+ dev-libs/libxml2:2
+ ~media-sound/audacious-${PV}[gtk?,qt5?]
+ aac? ( >=media-libs/faad2-2.7 )
+ alsa? ( >=media-libs/alsa-lib-1.0.16 )
+ ampache? ( www-apps/ampache )
+ aosd? (
+ x11-libs/libXrender
+ x11-libs/libXcomposite
+ )
+ bs2b? ( media-libs/libbs2b )
+ cdda? (
+ >=media-libs/libcddb-1.2.1
+ dev-libs/libcdio-paranoia
+ )
+ cue? ( media-libs/libcue )
+ ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
+ flac? (
+ >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.2.1-r1
+ )
+ fluidsynth? ( media-sound/fluidsynth )
+ http? ( >=net-libs/neon-0.26.4 )
+ gtk? (
+ x11-libs/gtk+:2
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ media-libs/adplug
+ )
+ jack? (
+ >=media-libs/bio2jack-0.4
+ media-sound/jack-audio-connection-kit
+ )
+ lame? ( media-sound/lame )
+ libnotify? ( x11-libs/libnotify )
+ libsamplerate? ( media-libs/libsamplerate )
+ lirc? ( app-misc/lirc )
+ mms? ( >=media-libs/libmms-0.3 )
+ modplug? ( media-libs/libmodplug )
+ mp3? ( >=media-sound/mpg123-1.12.1 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ scrobbler? ( net-misc/curl )
+ sdl? ( media-libs/libsdl2[sound] )
+ sid? ( >=media-libs/libsidplayfp-1.0.0 )
+ sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
+ soxr? ( media-libs/soxr )
+ vorbis? (
+ >=media-libs/libvorbis-1.2.0
+ >=media-libs/libogg-1.1.3
+ )
+ wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
+
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ if ! use mp3 ; then
+ ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+ fi
+
+ econf \
+ --enable-mpris2 \
+ --enable-songchange \
+ --enable-speedpitch \
+ --disable-oss4 \
+ --disable-qtaudio \
+ --disable-qtglspectrum \
+ --disable-coreaudio \
+ --disable-sndio \
+ $(use_enable aac) \
+ $(use_enable alsa) \
+ $(use_enable ampache) \
+ $(use_enable aosd) \
+ $(use_enable bs2b) \
+ $(use_enable cdda cdaudio) \
+ $(use_enable cue) \
+ $(use_enable flac) \
+ $(use_enable fluidsynth amidiplug) \
+ $(use_enable flac filewriter) \
+ $(use_enable gme console) \
+ $(use_enable gtk) \
+ $(use_enable hotkeys hotkey) \
+ $(use_enable http neon) \
+ $(use_enable jack) \
+ $(use_enable gnome gnomeshortcuts) \
+ $(use_enable lame filewriter_mp3) \
+ $(use_enable libnotify notify) \
+ $(use_enable libsamplerate resample) \
+ $(use_enable lirc) \
+ $(use_enable mms) \
+ $(use_enable modplug) \
+ $(use_enable mp3 mpg123) \
+ $(use_enable nls) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable qt5 qt) \
+ $(use_enable scrobbler scrobbler2) \
+ $(use_enable sdl sdlout) \
+ $(use_enable sid) \
+ $(use_enable sndfile) \
+ $(use_enable soxr) \
+ $(use_enable vorbis) \
+ $(use_enable wavpack) \
+ $(use_with ffmpeg ffmpeg $(usex libav libav ffmpeg))
+}
diff --git a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
new file mode 100644
index 000000000000..2b9250e27221
--- /dev/null
+++ b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/audacious-media-player/audacious-plugins.git"
+else
+ SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="aac +adplug alsa ampache aosd bs2b cdda cue ffmpeg flac fluidsynth gnome hotkeys http gme gtk jack lame libav
+ libnotify libsamplerate lirc mms modplug mp3 nls pulseaudio qt5 scrobbler sdl sid sndfile soxr vorbis wavpack"
+REQUIRED_USE="
+ ^^ ( gtk qt5 )
+ qt5? ( !libnotify )
+ || ( alsa jack pulseaudio sdl )"
+
+# The following plugins REQUIRE a GUI build of audacious, because non-GUI
+# builds do NOT install the libaudgui library & headers.
+# Plugins without a configure option:
+# alarm
+# albumart
+# delete-files
+# ladspa
+# playlist-manager
+# search-tool
+# skins
+# vtx
+# Plugins with a configure option:
+# glspectrum
+# gtkui
+# hotkey
+# notify
+# statusicon
+RDEPEND="
+ app-arch/unzip
+ dev-libs/dbus-glib
+ dev-libs/glib[utils]
+ dev-libs/libxml2:2
+ ~media-sound/audacious-${PV}[gtk?,qt5?]
+ aac? ( >=media-libs/faad2-2.7 )
+ alsa? ( >=media-libs/alsa-lib-1.0.16 )
+ ampache? ( www-apps/ampache )
+ aosd? (
+ x11-libs/libXrender
+ x11-libs/libXcomposite
+ )
+ bs2b? ( media-libs/libbs2b )
+ cdda? (
+ >=media-libs/libcddb-1.2.1
+ dev-libs/libcdio-paranoia
+ )
+ cue? ( media-libs/libcue )
+ ffmpeg? ( >=virtual/ffmpeg-0.7.3 )
+ flac? (
+ >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.2.1-r1
+ )
+ fluidsynth? ( media-sound/fluidsynth )
+ http? ( >=net-libs/neon-0.26.4 )
+ gtk? (
+ x11-libs/gtk+:2
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ media-libs/adplug
+ )
+ jack? (
+ >=media-libs/bio2jack-0.4
+ media-sound/jack-audio-connection-kit
+ )
+ lame? ( media-sound/lame )
+ libnotify? ( x11-libs/libnotify )
+ libsamplerate? ( media-libs/libsamplerate )
+ lirc? ( app-misc/lirc )
+ mms? ( >=media-libs/libmms-0.3 )
+ modplug? ( media-libs/libmodplug )
+ mp3? ( >=media-sound/mpg123-1.12.1 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
+ scrobbler? ( net-misc/curl )
+ sdl? ( media-libs/libsdl2[sound] )
+ sid? ( >=media-libs/libsidplayfp-1.0.0 )
+ sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
+ soxr? ( media-libs/soxr )
+ vorbis? (
+ >=media-libs/libvorbis-1.2.0
+ >=media-libs/libogg-1.1.3
+ )
+ wavpack? ( >=media-sound/wavpack-4.50.1-r1 )"
+
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ if ! use mp3 ; then
+ ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+ fi
+
+ econf \
+ --enable-mpris2 \
+ --enable-songchange \
+ --enable-speedpitch \
+ --disable-oss4 \
+ --disable-qtaudio \
+ --disable-qtglspectrum \
+ --disable-coreaudio \
+ --disable-sndio \
+ $(use_enable aac) \
+ $(use_enable alsa) \
+ $(use_enable ampache) \
+ $(use_enable aosd) \
+ $(use_enable bs2b) \
+ $(use_enable cdda cdaudio) \
+ $(use_enable cue) \
+ $(use_enable flac) \
+ $(use_enable fluidsynth amidiplug) \
+ $(use_enable flac filewriter) \
+ $(use_enable gme console) \
+ $(use_enable gtk) \
+ $(use_enable hotkeys hotkey) \
+ $(use_enable http neon) \
+ $(use_enable jack) \
+ $(use_enable gnome gnomeshortcuts) \
+ $(use_enable lame filewriter_mp3) \
+ $(use_enable libnotify notify) \
+ $(use_enable libsamplerate resample) \
+ $(use_enable lirc) \
+ $(use_enable mms) \
+ $(use_enable modplug) \
+ $(use_enable mp3 mpg123) \
+ $(use_enable nls) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable qt5 qt) \
+ $(use_enable scrobbler scrobbler2) \
+ $(use_enable sdl sdlout) \
+ $(use_enable sid) \
+ $(use_enable sndfile) \
+ $(use_enable soxr) \
+ $(use_enable vorbis) \
+ $(use_enable wavpack) \
+ $(use_with ffmpeg ffmpeg $(usex libav libav ffmpeg))
+}
diff --git a/media-plugins/audacious-plugins/metadata.xml b/media-plugins/audacious-plugins/metadata.xml
index 10ff70693716..a6882603d286 100644
--- a/media-plugins/audacious-plugins/metadata.xml
+++ b/media-plugins/audacious-plugins/metadata.xml
@@ -1,26 +1,28 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
- <email>zx2c4@gentoo.org</email>
- <name>Jason A. Donenfeld</name>
-</maintainer>
-<maintainer type="project">
- <email>sound@gentoo.org</email>
- <name>Gentoo Sound project</name>
-</maintainer>
-<use>
- <flag name="adplug">Build with AdPlug (Adlib sound card emulation)
- support</flag>
- <flag name="aosd">Enable support for Audacious OSD</flag>
- <flag name="bs2b">Enable Bauer Bauer stereophonic-to-binaural
- headphone filter</flag>
- <flag name="cue">Support CUE sheets using the libcue library</flag>
- <flag name="fluidsynth">Support FluidSynth as MIDI synth backend</flag>
- <flag name="http">Support HTTP streams through neon</flag>
- <flag name="gtk3">Link against version 3 of the GIMP Toolkit instead of version 2 (x11-libs/gtk+)</flag>
- <flag name="midi">Build with amidi-plug (MIDI synth) support</flag>
- <flag name="scrobbler">Build with scrobbler/LastFM submission support</flag>
- <flag name="sid">Build with SID (Commodore 64 Audio) support</flag>
-</use>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <use>
+ <flag name="adplug">Build with AdPlug (Adlib sound card emulation) support</flag>
+ <flag name="ampache">Support controlling audacious via <pkg>www-apps/ampache</pkg></flag>
+ <flag name="aosd">Enable support for Audacious OSD</flag>
+ <flag name="bs2b">Enable Bauer Bauer stereophonic-to-binaural headphone filter</flag>
+ <flag name="cue">Support CUE sheets using the libcue library</flag>
+ <flag name="fluidsynth">Support FluidSynth as MIDI synth backend</flag>
+ <flag name="gme">Support various gaming console music formats</flag>
+ <flag name="gtk3">Link against version 3 of the GIMP Toolkit instead of version 2 (x11-libs/gtk+)</flag>
+ <flag name="hotkeys">Enable support for controlling via hotkeys</flag>
+ <flag name="http">Support HTTP streams through neon</flag>
+ <flag name="midi">Build with amidi-plug (MIDI synth) support</flag>
+ <flag name="scrobbler">Build with scrobbler/LastFM submission support</flag>
+ <flag name="sid">Build with SID (Commodore 64 Audio) support</flag>
+ <flag name="soxr">Build with SoX Resampler support</flag>
+ </use>
</pkgmetadata>