summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/gst-plugins-libnice/gst-plugins-libnice-0.1.10-r100.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/gst-plugins-libnice/gst-plugins-libnice-0.1.10-r100.ebuild')
-rw-r--r--media-plugins/gst-plugins-libnice/gst-plugins-libnice-0.1.10-r100.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-libnice/gst-plugins-libnice-0.1.10-r100.ebuild b/media-plugins/gst-plugins-libnice/gst-plugins-libnice-0.1.10-r100.ebuild
new file mode 100644
index 000000000000..27eef50a79aa
--- /dev/null
+++ b/media-plugins/gst-plugins-libnice/gst-plugins-libnice-0.1.10-r100.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib-minimal toolchain-funcs
+
+DESCRIPTION="GStreamer plugin for ICE (RFC 5245) support"
+HOMEPAGE="http://nice.freedesktop.org/wiki/"
+MY_P=libnice-${PV}
+SRC_URI="http://nice.freedesktop.org/releases/${MY_P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 LGPL-2.1 )"
+SLOT="1.0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ ~net-libs/libnice-${PV}[${MULTILIB_USEDEP}]
+ media-libs/gstreamer:${SLOT}[${MULTILIB_USEDEP}]
+ media-libs/gst-plugins-base:${SLOT}[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e 's:$(top_builddir)/nice/libnice.la:$(NICE_LIBS):' \
+ -i gst/Makefile.{am,in} || die "sed failed"
+}
+
+multilib_src_configure() {
+ # gupnp is not used in the gst plugin
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static \
+ --disable-static-plugins \
+ --without-gstreamer-0.10 \
+ --with-gstreamer \
+ --disable-introspection \
+ --disable-gupnp
+}
+
+multilib_src_compile() {
+ emake -C gst \
+ NICE_LIBS="$($(tc-getPKG_CONFIG) --libs-only-l nice)"
+}
+
+multilib_src_test() {
+ :
+}
+
+multilib_src_install() {
+ emake -C gst DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --modules
+}