summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-05-19 01:34:31 -0400
committerCraig Andrews <candrews@gentoo.org>2021-05-19 01:35:11 -0400
commit1e0d0ac883e92275a624c49f8d7f43ddcd4027ba (patch)
tree32070b1069164ab379bad27eef95bb1c437a09e9 /media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild
parentgnome-extra/gnome-shell-extensions: add ~ppc64 keyword (diff)
downloadgentoo-1e0d0ac883e92275a624c49f8d7f43ddcd4027ba.tar.gz
gentoo-1e0d0ac883e92275a624c49f8d7f43ddcd4027ba.tar.bz2
gentoo-1e0d0ac883e92275a624c49f8d7f43ddcd4027ba.zip
media-plugins/kodi-peripheral-joystick: 1.7.2 version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild')
-rw-r--r--media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild
new file mode 100644
index 000000000000..0afe32da893f
--- /dev/null
+++ b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
+HOMEPAGE="https://github.com/xbmc/peripheral.joystick"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_BRANCH="Matrix"
+ EGIT_REPO_URI="https://github.com/xbmc/peripheral.joystick.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Matrix"
+ SRC_URI="https://github.com/xbmc/peripheral.joystick/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/peripheral.joystick-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ dev-libs/libpcre
+ dev-libs/tinyxml
+ "
+RDEPEND="
+ ${DEPEND}
+ "