summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-arghdirector
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-arghdirector')
-rw-r--r--media-plugins/vdr-arghdirector/Manifest1
-rw-r--r--media-plugins/vdr-arghdirector/files/vdr-arghdirector-0.2.6-i18n.patch30
-rw-r--r--media-plugins/vdr-arghdirector/files/vdr-arghdirector-0.2.6-vdr-1.5.3.diff15
-rw-r--r--media-plugins/vdr-arghdirector/metadata.xml12
-rw-r--r--media-plugins/vdr-arghdirector/vdr-arghdirector-0.2.6.ebuild25
5 files changed, 83 insertions, 0 deletions
diff --git a/media-plugins/vdr-arghdirector/Manifest b/media-plugins/vdr-arghdirector/Manifest
new file mode 100644
index 000000000000..733c449086ac
--- /dev/null
+++ b/media-plugins/vdr-arghdirector/Manifest
@@ -0,0 +1 @@
+DIST vdr-arghdirector-0.2.6.tar.gz 22119 RMD160 69f8c726b63786606ea53957a7d3b4dfe3006fb1 SHA1 9030fda40f66b64188374df1a5de7d3d53c4fc46 SHA256 d7206796560b4fdc7693f338ba4f1a8f4d416ae64fd60da195e4319527026b60
diff --git a/media-plugins/vdr-arghdirector/files/vdr-arghdirector-0.2.6-i18n.patch b/media-plugins/vdr-arghdirector/files/vdr-arghdirector-0.2.6-i18n.patch
new file mode 100644
index 000000000000..621a0469cfa2
--- /dev/null
+++ b/media-plugins/vdr-arghdirector/files/vdr-arghdirector-0.2.6-i18n.patch
@@ -0,0 +1,30 @@
+diff --git a/arghdirector.c b/arghdirector.c
+index f01f11d..56d3fe0 100755
+--- a/arghdirector.c
++++ b/arghdirector.c
+@@ -85,7 +85,9 @@ bool cPluginDirector::ProcessArgs(int argc, char *argv[])
+ bool cPluginDirector::Start(void)
+ {
+ // Start any background activities the plugin shall perform.
++#if VDRVERSNUM < 10727
+ RegisterI18n(Phrases);
++#endif
+
+ #if VDRVERSNUM >= 10332
+ if(autoStart == 1)
+diff --git a/i18n.h b/i18n.h
+index 22cce61..1117745 100755
+--- a/i18n.h
++++ b/i18n.h
+@@ -9,8 +9,11 @@
+ #ifndef _I18N__H
+ #define _I18N__H
+
++#include <vdr/config.h>
+ #include <vdr/i18n.h>
+
++#if VDRVERSNUM < 10727
+ extern const tI18nPhrase Phrases[];
++#endif
+
+ #endif //_I18N__H
diff --git a/media-plugins/vdr-arghdirector/files/vdr-arghdirector-0.2.6-vdr-1.5.3.diff b/media-plugins/vdr-arghdirector/files/vdr-arghdirector-0.2.6-vdr-1.5.3.diff
new file mode 100644
index 000000000000..ed54760fcb82
--- /dev/null
+++ b/media-plugins/vdr-arghdirector/files/vdr-arghdirector-0.2.6-vdr-1.5.3.diff
@@ -0,0 +1,15 @@
+diff -ru arghdirector-0.2.6-orig/directorosd.c arghdirector-0.2.6/directorosd.c
+--- arghdirector-0.2.6-orig/directorosd.c 2007-06-24 15:28:04.733376979 +0200
++++ arghdirector-0.2.6/directorosd.c 2007-06-24 15:29:34.741637063 +0200
+@@ -323,7 +323,11 @@
+ char *buffer=0;
+ asprintf(&buffer,"1 %s %d", Channel->Name(), number);
+
++#if VDRVERSNUM < 10503
+ int theHeigth = font->Height('A');
++#else
++ int theHeigth = font->Height("A");
++#endif
+ int m_height = (number * theHeigth) + 10;
+
+ //get the width
diff --git a/media-plugins/vdr-arghdirector/metadata.xml b/media-plugins/vdr-arghdirector/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-arghdirector/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-arghdirector/vdr-arghdirector-0.2.6.ebuild b/media-plugins/vdr-arghdirector/vdr-arghdirector-0.2.6.ebuild
new file mode 100644
index 000000000000..320917057bbb
--- /dev/null
+++ b/media-plugins/vdr-arghdirector/vdr-arghdirector-0.2.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: use the multifeed option of some Premiere channels - fork of vdr-director"
+HOMEPAGE="http://www.arghgra.de/arghdirector.html"
+SRC_URI="http://www.arghgra.de/vdr-arghdirector-0.2.6.tar.gz
+ mirror://vdrfiles/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.34"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-vdr-1.5.3.diff"
+ "${FILESDIR}/${P}-i18n.patch"
+ )