summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2024-06-20 20:16:33 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 21:09:48 +0200
commit46555d4fe5d4d71fd207ed6f3ea454a298026557 (patch)
treef91adc443e3a1e7ba19809b3cbd95d260a993586 /media-plugins
parentmedia-plugins/vdr-radio: drop 0.9.1 (diff)
downloadgentoo-46555d4fe5d4d71fd207ed6f3ea454a298026557.tar.gz
gentoo-46555d4fe5d4d71fd207ed6f3ea454a298026557.tar.bz2
gentoo-46555d4fe5d4d71fd207ed6f3ea454a298026557.zip
media-plugins/vdr-radio: update EAPI 7 -> 8
fix pkgcheck issue fix clang compile error new HOMEPAGE + SRC_URI Closes: https://bugs.gentoo.org/925755 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/37230 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-radio/Manifest2
-rw-r--r--media-plugins/vdr-radio/metadata.xml7
-rw-r--r--media-plugins/vdr-radio/vdr-radio-1.1.0-r1.ebuild (renamed from media-plugins/vdr-radio/vdr-radio-1.1.0.ebuild)18
3 files changed, 17 insertions, 10 deletions
diff --git a/media-plugins/vdr-radio/Manifest b/media-plugins/vdr-radio/Manifest
index 2e08cea5194e..ed7b499ba7fe 100644
--- a/media-plugins/vdr-radio/Manifest
+++ b/media-plugins/vdr-radio/Manifest
@@ -1 +1 @@
-DIST vdr-plugin-radio-1.1.0.tar.gz 710385 BLAKE2B fa9c692d528d718ace371359fea915eaf972b8ec759c28f86f52b9564c4f6e405da87639522af9a2c24138808351ee421d112dfacf3954d9779da9307a1f0a94 SHA512 d6c5ea7c457b5611b689bd5bc051c185feb108be6d82ea45ae9e9847a86cd06df38b38a1851bcdcf49808111cd1e9aea1f08decca66973c8020592d3a261aae6
+DIST vdr-radio-1.1.0.tgz 710385 BLAKE2B fa9c692d528d718ace371359fea915eaf972b8ec759c28f86f52b9564c4f6e405da87639522af9a2c24138808351ee421d112dfacf3954d9779da9307a1f0a94 SHA512 d6c5ea7c457b5611b689bd5bc051c185feb108be6d82ea45ae9e9847a86cd06df38b38a1851bcdcf49808111cd1e9aea1f08decca66973c8020592d3a261aae6
diff --git a/media-plugins/vdr-radio/metadata.xml b/media-plugins/vdr-radio/metadata.xml
index d311c1f56233..20ea54b8c28f 100644
--- a/media-plugins/vdr-radio/metadata.xml
+++ b/media-plugins/vdr-radio/metadata.xml
@@ -13,8 +13,11 @@
<email>vdr@gentoo.org</email>
<name>Gentoo VDR Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">vdr-projects/vdr-plugin-radio</remote-id>
+ </upstream>
<longdescription>
- This Plugin display a background image while the vdr is switcht to radio channels.
- Also it supports RDS on radio channels.
+ This Plugin displays a background image while the vdr is switched to radio channels.
+ It also supports RDS text on radio channels.
</longdescription>
</pkgmetadata>
diff --git a/media-plugins/vdr-radio/vdr-radio-1.1.0.ebuild b/media-plugins/vdr-radio/vdr-radio-1.1.0-r1.ebuild
index c99c2cec7b6c..f2738e298b2d 100644
--- a/media-plugins/vdr-radio/vdr-radio-1.1.0.ebuild
+++ b/media-plugins/vdr-radio/vdr-radio-1.1.0-r1.ebuild
@@ -1,22 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit vdr-plugin-2
DESCRIPTION="VDR plugin: show background image for radio and decode RDS Text"
-HOMEPAGE="https://projects.vdr-developer.org/projects/vdr-plugin-radio"
-SRC_URI="https://projects.vdr-developer.org/git/vdr-plugin-radio.git/snapshot/vdr-plugin-radio-${PV}.tar.gz"
+HOMEPAGE="https://github.com/vdr-projects/vdr-plugin-radio/"
+SRC_URI="https://github.com/vdr-projects/vdr-plugin-radio/archive/refs/tags/${PV}.tar.gz -> ${P}.tgz"
+S="${WORKDIR}/vdr-plugin-radio-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-RDEPEND="media-video/vdr"
-DEPEND="${RDEPEND}"
+DEPEND="media-video/vdr"
+RDEPEND="${DEPEND}"
-S="${WORKDIR}/vdr-plugin-radio-${PV}"
+src_prepare() {
+ sed -e '/^CXXFLAGS +=/ s/$/ -std=c++14/' -i Makefile || die
+ vdr-plugin-2_src_prepare
+}
src_install() {
vdr-plugin-2_src_install