summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-07-04 06:15:37 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-04 06:15:37 +0200
commitcbf70fda6fd3f0472d14040b781dd76db5ac3a13 (patch)
treefa2b37daaaa2ef4866bd077cce4777ea447040c6 /media-sound/frescobaldi/frescobaldi-3.1.3.ebuild
parentdev-util/visualvm: bump to 2.0.7 (diff)
downloadgentoo-cbf70fda6fd3f0472d14040b781dd76db5ac3a13.tar.gz
gentoo-cbf70fda6fd3f0472d14040b781dd76db5ac3a13.tar.bz2
gentoo-cbf70fda6fd3f0472d14040b781dd76db5ac3a13.zip
media-sound/frescobaldi: bump to 3.1.3
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/frescobaldi/frescobaldi-3.1.3.ebuild')
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/frescobaldi-3.1.3.ebuild b/media-sound/frescobaldi/frescobaldi-3.1.3.ebuild
new file mode 100644
index 000000000000..e600ca8d596b
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-3.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 xdg
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="https://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/PyQt5[gui,network,printsupport,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/python-ly[${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ media-sound/lilypond"
+RDEPEND="${DEPEND}
+ x11-themes/tango-icon-theme
+"
+
+python_prepare_all() {
+ rm -r frescobaldi_app/icons/Tango || die "failed to remove tango icon theme"
+ distutils-r1_python_prepare_all
+}