summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-10 03:50:58 +0000
committerSam James <sam@gentoo.org>2021-06-10 03:54:46 +0000
commitc1036ae01b7030aab9b577e7bd14b607ea4420ac (patch)
treebfbb0f3b2f65e64d07528212478e81efdafc544a /media-sound/gpodder
parentapp-admin/rasdaemon: fix sysconfig dir (diff)
downloadgentoo-c1036ae01b7030aab9b577e7bd14b607ea4420ac.tar.gz
gentoo-c1036ae01b7030aab9b577e7bd14b607ea4420ac.tar.bz2
gentoo-c1036ae01b7030aab9b577e7bd14b607ea4420ac.zip
media-sound/gpodder: add 3.10.20
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/gpodder')
-rw-r--r--media-sound/gpodder/Manifest1
-rw-r--r--media-sound/gpodder/gpodder-3.10.20.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/gpodder/Manifest b/media-sound/gpodder/Manifest
index 78ef06e18e82..050a5c1c75f4 100644
--- a/media-sound/gpodder/Manifest
+++ b/media-sound/gpodder/Manifest
@@ -1 +1,2 @@
DIST gpodder-3.10.16.tar.gz 1058386 BLAKE2B d73bc8a9d9d2cfe642a6c1e7ae3e7811e05db8c1ebf566904e669a5f9d029c6bce73599da737d25f42c4740d23537b1c414e7a23cf15076394fb714a2f33c79c SHA512 ce9525864e5a640dd82fb535021d63e1d1ddeb7785774b00c668ff86a279a45e075ab7488120ec93d1a07a0a943daa0abb786f822d74866e0fd8c6713d7f8531
+DIST gpodder-3.10.20.tar.gz 1081171 BLAKE2B b2a07a3d5ce02cc46d7dd5999287b6e0bb96149f2fbf613b0d70b8d3b04d4cd29dcd1b78b4584709d1613c9a5478d39c3cb9be35a274358d56aa593f0196e6b2 SHA512 93cae9cc6d7f3a7754e24f7e962d195788f5f344992a4a3f3be9fd9acf419728b94ce009e1a2e14faa64803ebba098e8199a8d43ed33f5f3e02eabde1fe5c3be
diff --git a/media-sound/gpodder/gpodder-3.10.20.ebuild b/media-sound/gpodder/gpodder-3.10.20.ebuild
new file mode 100644
index 000000000000..3be14aeb7ee0
--- /dev/null
+++ b/media-sound/gpodder/gpodder-3.10.20.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 optfeature xdg
+
+DESCRIPTION="A free cross-platform podcast aggregator"
+HOMEPAGE="https://gpodder.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+dbus bluetooth kernel_linux mtp test"
+RESTRICT="!test? ( test )"
+
+# As in Fedora: re-enable >=dev-python/eyeD3-0.7[${PYTHON_USEDEP}] and
+# ipod? ( media-libs/libgpod[python,${PYTHON_USEDEP}] ) once they
+# support python3
+COMMON_DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.22.0:3[${PYTHON_USEDEP}]
+ >=dev-python/podcastparser-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/mygpoclient-1.8[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ ')
+ bluetooth? ( net-wireless/bluez )
+ mtp? ( >=media-libs/libmtp-1.0.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ kernel_linux? ( sys-apps/iproute2 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-apps/help2man
+ test? (
+ dev-python/minimock
+ dev-python/pytest-localserver
+ )
+"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:--cov=gpodder::' makefile || die
+}
+
+src_test() {
+ emake releasetest
+}
+
+src_install() {
+ emake PYTHON=${EPYTHON} DESTDIR="${D}" install
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "for the youtube-dl extension" net-misc/youtube-dl
+}