summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-04-03 21:08:01 +0400
committerMiroslav Šulc <fordfrog@gentoo.org>2024-06-29 12:14:45 +0200
commit455ca0943d2c4594dcc8d79b1781cb41bb059d8d (patch)
treeeb9a0fad337e91faf19b17696170bc0ca5d68848 /media-sound/gstreamripper/gstreamripper-0.2.ebuild
parentmedia-sound/awesfx: update EAPI 7 -> 8, fix wrong function signature (diff)
downloadgentoo-455ca0943d2c4594dcc8d79b1781cb41bb059d8d.tar.gz
gentoo-455ca0943d2c4594dcc8d79b1781cb41bb059d8d.tar.bz2
gentoo-455ca0943d2c4594dcc8d79b1781cb41bb059d8d.zip
media-sound/gstreamripper: Fix C99 errors; update EAPI 7 -> 8
There was a number of implicit declarations and wrongs made with pointer assignments. Patch fixes them, also supercedes previous pull request with wrongly made casts by correct functions from glib. Closes:https://bugs.gentoo.org/871012 Closes:https://bugs.gentoo.org/919182 Closes:https://bugs.gentoo.org/885531 Closes:#30057 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36080 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/gstreamripper/gstreamripper-0.2.ebuild')
-rw-r--r--media-sound/gstreamripper/gstreamripper-0.2.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/media-sound/gstreamripper/gstreamripper-0.2.ebuild b/media-sound/gstreamripper/gstreamripper-0.2.ebuild
deleted file mode 100644
index 98a7de6e4bf2..000000000000
--- a/media-sound/gstreamripper/gstreamripper-0.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop
-
-MY_P=GStreamripperX-${PV}
-
-DESCRIPTION="A GTK+ toolkit based frontend for streamripper"
-HOMEPAGE="https://sourceforge.net/projects/gstreamripper/"
-SRC_URI="https://downloads.sourceforge.net/gstreamripper/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-
-RDEPEND="
- x11-libs/gtk+:2
- media-sound/streamripper"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_compile() {
- emake CFLAGS="${CFLAGS}"
-}
-
-src_install() {
- local docdir="${EPREFIX}/usr/share/doc/${PF}"
- emake \
- DESTDIR="${D}" \
- gstreamripperxdocdir="${docdir}" \
- install
- einstalldocs
-
- rm "${ED}"/${docdir}/COPYING || die
-
- make_desktop_entry gstreamripperx GStreamripperX
-}