summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-02 03:45:35 +0100
committerSam James <sam@gentoo.org>2022-06-02 03:59:59 +0100
commit7a461f04217706838471b36a5dc8233f2ed6853b (patch)
treec5d437012eb2e83729830ea109e58a8e7411fd15 /media-sound/musescore
parentapp-metrics/redis_exporter: add 1.38.0 (diff)
downloadgentoo-7a461f04217706838471b36a5dc8233f2ed6853b.tar.gz
gentoo-7a461f04217706838471b36a5dc8233f2ed6853b.tar.bz2
gentoo-7a461f04217706838471b36a5dc8233f2ed6853b.zip
media-sound/musescore: fix finding qmake
Upstream need to fix their Qt handling but w/e. Closes: https://bugs.gentoo.org/766111 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/musescore')
-rw-r--r--media-sound/musescore/musescore-3.6.2.ebuild7
-rw-r--r--media-sound/musescore/musescore-9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/media-sound/musescore/musescore-3.6.2.ebuild b/media-sound/musescore/musescore-3.6.2.ebuild
index 96f936a41a63..5cc3b579f8cd 100644
--- a/media-sound/musescore/musescore-3.6.2.ebuild
+++ b/media-sound/musescore/musescore-3.6.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
CHECKREQS_DISK_BUILD=3500M
-inherit cmake xdg check-reqs
+inherit cmake qmake-utils xdg check-reqs
if [[ ${PV} == "9999" ]]; then
inherit git-r3
@@ -83,6 +83,9 @@ src_prepare() {
}
src_configure() {
+ # bug #766111
+ export PATH="$(qt5_get_bindir):${PATH}"
+
local mycmakeargs=(
-DAEOLUS=OFF # does not compile
-DBUILD_ALSA="$(usex alsa)"
diff --git a/media-sound/musescore/musescore-9999.ebuild b/media-sound/musescore/musescore-9999.ebuild
index 01dcab44b226..c7f38acd5608 100644
--- a/media-sound/musescore/musescore-9999.ebuild
+++ b/media-sound/musescore/musescore-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
CHECKREQS_DISK_BUILD=3500M
-inherit cmake xdg check-reqs
+inherit cmake qmake-utils xdg check-reqs
if [[ ${PV} == "9999" ]]; then
inherit git-r3
@@ -79,6 +79,9 @@ src_prepare() {
}
src_configure() {
+ # bug #766111
+ export PATH="$(qt5_get_bindir):${PATH}"
+
local mycmakeargs=(
-DAEOLUS=OFF # does not compile
-DBUILD_ALSA="$(usex alsa)"