summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2018-11-28 21:56:31 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2018-11-28 21:58:24 -0500
commitf9fd75e4fd9daac925169975d022d03c814298b1 (patch)
tree1050a590a0bca08f2341a239a1201d68816d4f54 /media-sound/playerctl/playerctl-2.0.1.ebuild
parentapp-forensics/sleuthkit: bump to 4.6.4 (diff)
downloadgentoo-f9fd75e4fd9daac925169975d022d03c814298b1.tar.gz
gentoo-f9fd75e4fd9daac925169975d022d03c814298b1.tar.bz2
gentoo-f9fd75e4fd9daac925169975d022d03c814298b1.zip
media-sound/playerctl: bump to 2.0.1
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-sound/playerctl/playerctl-2.0.1.ebuild')
-rw-r--r--media-sound/playerctl/playerctl-2.0.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/playerctl/playerctl-2.0.1.ebuild b/media-sound/playerctl/playerctl-2.0.1.ebuild
new file mode 100644
index 000000000000..18ed3cb3fc51
--- /dev/null
+++ b/media-sound/playerctl/playerctl-2.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson xdg-utils
+
+DESCRIPTION="A CLI utility to control media players over MPRIS"
+HOMEPAGE="https://github.com/acrisci/playerctl"
+SRC_URI="https://github.com/acrisci/playerctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc introspection"
+
+RDEPEND="
+ dev-libs/glib:2
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+# Override the meson dependency in MESON_DEPEND of meson.eclass
+# The eclass depends on '>=dev-util/meson-0.40.0' as of writing this
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/meson-0.46.0
+ doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc gtk-doc)
+ $(meson_use introspection)
+ )
+
+ xdg_environment_reset # 596166
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+}