summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-09-09 01:00:10 +0300
committerMarek Szuba <marecki@gentoo.org>2016-09-13 10:45:40 +0200
commit05ccefafff83dc9190ac48572116eeab854f3781 (patch)
treef7889a55944c8f01997cee659d8f59a935ffed9a /media-sound/pms/pms-9999.ebuild
parentmedia-sound/pms: fix numerous QA issues in 0.42-r2 (diff)
downloadgentoo-05ccefafff83dc9190ac48572116eeab854f3781.tar.gz
gentoo-05ccefafff83dc9190ac48572116eeab854f3781.tar.bz2
gentoo-05ccefafff83dc9190ac48572116eeab854f3781.zip
media-sound/pms: live ebuild overhaul
fix ncurses slot dep specify correct license fix automagic dependency on autodoc add missing depends (dev-util/intltool and dev-util/gettext) add missing rdepend on virtual/libintl specify gcc 4.9 as the minimal gcc version Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-sound/pms/pms-9999.ebuild')
-rw-r--r--media-sound/pms/pms-9999.ebuild28
1 files changed, 21 insertions, 7 deletions
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
index af181ef46d25..b7aed94e14ae 100644
--- a/media-sound/pms/pms-9999.ebuild
+++ b/media-sound/pms/pms-9999.ebuild
@@ -4,30 +4,43 @@
EAPI=6
-inherit autotools flag-o-matic git-r3
+inherit autotools flag-o-matic git-r3 toolchain-funcs versionator
DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
HOMEPAGE="https://ambientsound.github.io/pms"
EGIT_REPO_URI="https://github.com/ambientsound/pms.git"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-IUSE="regex"
+IUSE="regex doc"
RDEPEND="
- sys-libs/ncurses:=[unicode]
+ sys-libs/ncurses:0=[unicode]
dev-libs/glib:2
media-libs/libmpdclient
+ virtual/libintl
"
DEPEND="
virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ doc? ( app-text/pandoc )
${RDEPEND}
"
DOCS=( AUTHORS README TODO )
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use regex; then
+ if tc-is-gcc && ! version_is_at_least 4.9 $(gcc-version); then
+ die "Clang or GCC >= 4.9 is required for proper regex support"
+ fi
+ fi
+}
+
src_prepare() {
+ eapply "${FILESDIR}/pms-9999-fix-automagic-dep.patch"
eapply_user
eautoreconf
@@ -35,9 +48,10 @@ src_prepare() {
src_configure() {
# Required for ncurses[tinfo]
- append-cppflags $(pkg-config --cflags ncursesw)
- append-libs $(pkg-config --libs ncursesw)
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags ncursesw)
+ append-libs $($(tc-getPKG_CONFIG) --libs ncursesw)
econf \
- $(use_enable regex)
+ $(use_enable regex) \
+ $(use_with doc)
}