summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-17 05:49:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-17 05:54:27 +0100
commit1bf8d3f94b384a467b4fffb9da16712a1b9009e3 (patch)
tree1d9cd3631456ff9c94b285f2105c8d8a52f0bc40 /media-sound/pragha
parentdev-libs/hiredis: enable async tests (diff)
downloadgentoo-1bf8d3f94b384a467b4fffb9da16712a1b9009e3.tar.gz
gentoo-1bf8d3f94b384a467b4fffb9da16712a1b9009e3.tar.bz2
gentoo-1bf8d3f94b384a467b4fffb9da16712a1b9009e3.zip
media-sound/pragha: Correct dependencies
Closes: https://bugs.gentoo.org/881567 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/pragha')
-rw-r--r--media-sound/pragha/pragha-1.3.99.1-r1.ebuild (renamed from media-sound/pragha/pragha-1.3.99.1.ebuild)37
1 files changed, 24 insertions, 13 deletions
diff --git a/media-sound/pragha/pragha-1.3.99.1.ebuild b/media-sound/pragha/pragha-1.3.99.1-r1.ebuild
index 2667de64c421..5284653c476c 100644
--- a/media-sound/pragha/pragha-1.3.99.1.ebuild
+++ b/media-sound/pragha/pragha-1.3.99.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,18 +12,24 @@ SRC_URI="https://github.com/pragha-music-player/${PN}/releases/download/v${PV}/$
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="cdda +glyr grilo +keybinder koel lastfm libnotify mtp +peas +playlist rygel soup +udev"
+IUSE="
+ cdda +glyr grilo +keybinder koel lastfm libnotify mtp +peas
+ +playlist rygel soup +udev
+"
-COMMON_DEPEND=">=dev-db/sqlite-3.4:3=
+DEPEND="
+ >=dev-db/sqlite-3.4:3=
>=dev-libs/glib-2.42
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
>=media-libs/taglib-1.8:=
>=x11-libs/gtk+-3.14:3
>=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
- cdda? ( >=dev-libs/libcdio-0.90:=
+ cdda? (
+ >=dev-libs/libcdio-0.90:=
>=dev-libs/libcdio-paranoia-0.90:=
- >=media-libs/libcddb-1.3.0:= )
+ >=media-libs/libcddb-1.3.0:=
+ )
glyr? ( >=media-libs/glyr-1.0.1:= )
grilo? ( media-libs/grilo:0.3[network(+)] )
keybinder? ( >=dev-libs/keybinder-0.2.0:3 )
@@ -34,24 +40,29 @@ COMMON_DEPEND=">=dev-db/sqlite-3.4:3=
peas? ( >=dev-libs/libpeas-1.0.0[gtk] )
playlist? ( >=dev-libs/totem-pl-parser-2.26:= )
rygel? ( >=net-misc/rygel-0.26 )
- soup? ( >=net-libs/libsoup-2.38:= )
- udev? ( dev-libs/libgudev:= )"
-RDEPEND="${COMMON_DEPEND}
- media-plugins/gst-plugins-meta:1.0"
-DEPEND="${COMMON_DEPEND}
+ soup? ( >=net-libs/libsoup-2.38:2.4 )
+ udev? ( dev-libs/libgudev:= )
+"
+RDEPEND="
+ ${DEPEND}
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
dev-util/intltool
>=dev-util/xfce4-dev-tools-4.10
sys-devel/gettext
virtual/pkgconfig
- xfce-base/exo"
-REQUIRED_USE="glyr? ( peas )
+"
+REQUIRED_USE="
+ glyr? ( peas )
grilo? ( peas )
koel? ( soup )
libnotify? ( peas )
mtp? ( udev )
rygel? ( peas )
soup? ( peas )
- udev? ( peas )"
+ udev? ( peas )
+"
src_configure() {
local myconf=(