summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/streamripper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/streamripper')
-rw-r--r--media-sound/streamripper/Manifest1
-rw-r--r--media-sound/streamripper/metadata.xml8
-rw-r--r--media-sound/streamripper/streamripper-1.64.6.ebuild34
3 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/streamripper/Manifest b/media-sound/streamripper/Manifest
new file mode 100644
index 000000000000..e704b48c8a17
--- /dev/null
+++ b/media-sound/streamripper/Manifest
@@ -0,0 +1 @@
+DIST streamripper-1.64.6.tar.gz 900205 SHA256 c1d75f2e9c7b38fd4695be66eff4533395248132f3cc61f375196403c4d8de42 SHA512 8477086d0099f6de861f1c47112476c427073b6e8127bbaaa2dd3e7930fe9a5c6d9b2c68d4a317f1bc0b20c625e665d5c245189049d35468aa83cf51828d4428 WHIRLPOOL dd53b9178b248d8d177cbc1af6fb94782bd648aa91be9f96d072e936068e3a9ad7b1491b00c4ce0e432c53553e491ca91208cb9a0ddb82814cf4d556169fe096
diff --git a/media-sound/streamripper/metadata.xml b/media-sound/streamripper/metadata.xml
new file mode 100644
index 000000000000..f22b3e40ffce
--- /dev/null
+++ b/media-sound/streamripper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">streamripper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/streamripper/streamripper-1.64.6.ebuild b/media-sound/streamripper/streamripper-1.64.6.ebuild
new file mode 100644
index 000000000000..88c6910bdb29
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.64.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="http://streamripper.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="vorbis"
+
+RDEPEND="media-libs/libmad
+ media-libs/faad2
+ >=dev-libs/glib-2.16
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --without-included-libmad \
+ --without-included-argv \
+ $(use_with vorbis ogg)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES parse_rules.txt README THANKS
+}