summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-06-19 10:31:32 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-06-19 10:31:32 +0200
commit2165aeaeb5da99007497d355546b7f326ee4cb1b (patch)
tree0d7b2c7f20c2952fa36762e88e46c59e734ee2d3 /media-sound/volwheel/volwheel-0.2.9.ebuild
parentmedia-sound/cmusfm: bump to 0.4.0, dropped 0.3.3 due to api change (diff)
downloadgentoo-2165aeaeb5da99007497d355546b7f326ee4cb1b.tar.gz
gentoo-2165aeaeb5da99007497d355546b7f326ee4cb1b.tar.bz2
gentoo-2165aeaeb5da99007497d355546b7f326ee4cb1b.zip
media-sound/volwheel: bump to 0.2.9
Closes: https://bugs.gentoo.org/782760 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/volwheel/volwheel-0.2.9.ebuild')
-rw-r--r--media-sound/volwheel/volwheel-0.2.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-sound/volwheel/volwheel-0.2.9.ebuild b/media-sound/volwheel/volwheel-0.2.9.ebuild
new file mode 100644
index 000000000000..e1c95db7ae37
--- /dev/null
+++ b/media-sound/volwheel/volwheel-0.2.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="A volume control trayicon with mouse wheel support"
+HOMEPAGE="https://oliwer.net/b/volwheel.html"
+SRC_URI="https://github.com/oliwer/volwheel/archive/refs/tags/v0.2.9.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="alsa"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Gtk2
+ alsa? ( media-sound/alsa-utils )"
+
+src_install() {
+ ./install.pl prefix="${EPREFIX}"/usr destdir="${D}" || die
+ einstalldocs
+}