summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-16 19:10:24 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-16 18:53:45 -0400
commit11cce9a0f58321c903c1b287b09e16e9d045e90b (patch)
tree75abf6dfa9889a6c5c0765019c0fa6e02233558d /media-sound
parentpackage.mask: update opentmpfiles mask message (diff)
downloadgentoo-11cce9a0f58321c903c1b287b09e16e9d045e90b.tar.gz
gentoo-11cce9a0f58321c903c1b287b09e16e9d045e90b.tar.bz2
gentoo-11cce9a0f58321c903c1b287b09e16e9d045e90b.zip
media-sound/gnome-music: Version bump to 45.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32857 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/gnome-music/Manifest1
-rw-r--r--media-sound/gnome-music/gnome-music-45.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
index 68e90bcf75d6..88a1569fad44 100644
--- a/media-sound/gnome-music/Manifest
+++ b/media-sound/gnome-music/Manifest
@@ -1 +1,2 @@
DIST gnome-music-44.0.tar.xz 1662928 BLAKE2B 3d9abcff6d4a220582974675c2966316259d01d0e34e805e8a9b6899f8ba44b5e70e7613c522c01bb831e0c966eb9181e7714b3226401453b34210a1322d81de SHA512 42985d13de8df838cd6beab8edc0d7c1a66c0018dbfcac2551779964194782efd2c6c6bc79c10e3bd1f8eb0a73cb783b51440338d7ff025e4e42d9196b78a847
+DIST gnome-music-45.0.tar.xz 1662996 BLAKE2B dedcb905ad135bd9bff569cb1168062e0f451479e00cddc3ac56dc506b938a090c1189495ee79b563a7e045e45cde40eb5095f4085c0a7de36fa1b876bc312f9 SHA512 9f919a3dd63826e7c31c57d62fbdd0dad463d401e213ca8aa119357d7203449ddd5b10b03d3ac66008399fadd6afcb3f7ae52b21fa9bf3f5c79eca6e859f67cc
diff --git a/media-sound/gnome-music/gnome-music-45.0.ebuild b/media-sound/gnome-music/gnome-music-45.0.ebuild
new file mode 100644
index 000000000000..d5e99af71213
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-45.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Music https://gitlab.gnome.org/GNOME/gnome-music/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.67.1:2
+ >=net-libs/gnome-online-accounts-3.35.90[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=gui-libs/gtk-4.5.0:4[introspection]
+ >=gui-libs/libadwaita-1.2:1=[introspection]
+ >=media-libs/libmediaart-1.9.1:2.0[introspection]
+ net-libs/libsoup:3.0[introspection]
+ app-misc/tracker:3=[introspection(+)]
+ >=x11-libs/pango-1.44:=
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.36.1:3[cairo,${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.14.0[${PYTHON_USEDEP}]
+ ')
+ >=media-libs/grilo-0.3.15-r1:0.3[introspection]
+ >=media-plugins/grilo-plugins-0.3.16:0.3[tracker]
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${DEPEND}
+ || (
+ app-misc/tracker-miners:3[gstreamer]
+ app-misc/tracker-miners:3[ffmpeg]
+ )
+ x11-libs/libnotify[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.3[tracker]
+ x11-misc/xdg-user-dirs
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/gnome-music
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}