summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-21 23:34:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-21 23:34:45 +0200
commit56904c25cf34e1dcc2098b34c1a516f88f3776a3 (patch)
treea469e0ef789a8f079662fd81ba0230fd1ab951db /media-sound
parentapp-emulation/punes: Fix compilation with Qt 5.11 (diff)
downloadgentoo-56904c25cf34e1dcc2098b34c1a516f88f3776a3.tar.gz
gentoo-56904c25cf34e1dcc2098b34c1a516f88f3776a3.tar.bz2
gentoo-56904c25cf34e1dcc2098b34c1a516f88f3776a3.zip
media-sound/musescore: Fix cmake (missing all.h)
Closes: https://bugs.gentoo.org/626618 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/musescore/files/musescore-2.1.0-pch.patch31
-rw-r--r--media-sound/musescore/musescore-2.1.0-r1.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/musescore/files/musescore-2.1.0-pch.patch b/media-sound/musescore/files/musescore-2.1.0-pch.patch
new file mode 100644
index 000000000000..d69d1cd2f654
--- /dev/null
+++ b/media-sound/musescore/files/musescore-2.1.0-pch.patch
@@ -0,0 +1,31 @@
+From 5e8024c683891be677075d74cedfbf424e36bc31 Mon Sep 17 00:00:00 2001
+From: mirabilos <tg@debian.org>
+Date: Sun, 4 Mar 2018 16:38:21 +0100
+Subject: [PATCH] Fix numerous reports of missing all.h during compilation
+
+When disabling PCH, the all.h copying code is no longer run before
+AUTOMOC=caused *_autogen targets, so we must run it earlier.
+
+From Debian
+---
+ CMakeLists.txt | 7 ++-----
+ 1 file changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 66b0ddfce8..7fdfffcc9b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -553,11 +553,8 @@ endif (NOT MINGW AND NOT APPLE)
+ #
+
+ # all.h is expected in PROJECT_BINARY_DIR by subdirs
+-add_custom_command(
+- OUTPUT ${PROJECT_BINARY_DIR}/all.h
+- COMMAND ${CMAKE_COMMAND}
+- ARGS -E copy ${PROJECT_SOURCE_DIR}/all.h ${PROJECT_BINARY_DIR}/all.h
+- DEPENDS ${PROJECT_SOURCE_DIR}/all.h
++execute_process(
++ COMMAND ${CMAKE_COMMAND} -E copy ${PROJECT_SOURCE_DIR}/all.h ${PROJECT_BINARY_DIR}/all.h
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+ )
+ \ No newline at end of file
diff --git a/media-sound/musescore/musescore-2.1.0-r1.ebuild b/media-sound/musescore/musescore-2.1.0-r1.ebuild
index 6abacb371c48..60cdd985217f 100644
--- a/media-sound/musescore/musescore-2.1.0-r1.ebuild
+++ b/media-sound/musescore/musescore-2.1.0-r1.ebuild
@@ -50,6 +50,7 @@ PATCHES=(
"${WORKDIR}/${P}-fix-buildsystem.patch"
"${FILESDIR}/${P}-qt-5.11.patch"
"${FILESDIR}/${P}-qtsingleapplication.patch"
+ "${FILESDIR}/${P}-pch.patch"
)
S="${WORKDIR}/MuseScore-${PV}"