summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-03-11 10:55:26 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-03-11 10:55:43 +0100
commit82d7fff2376298a0eb07fbd238cab4be31f05923 (patch)
treeca0b1e63b0e338488468d6adb53ad3ff0608f4a2 /media-sound
parentnet-misc/nextcloud-client: stabilize 3.11.1 for amd64 (diff)
downloadgentoo-82d7fff2376298a0eb07fbd238cab4be31f05923.tar.gz
gentoo-82d7fff2376298a0eb07fbd238cab4be31f05923.tar.bz2
gentoo-82d7fff2376298a0eb07fbd238cab4be31f05923.zip
media-sound/guitarix: bump to 0.45.0
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/guitarix/Manifest1
-rw-r--r--media-sound/guitarix/files/guitarix-0.45.0-fix-flto.patch11
-rw-r--r--media-sound/guitarix/files/guitarix-0.45.0-nostrip.patch30
-rw-r--r--media-sound/guitarix/guitarix-0.45.0.ebuild94
4 files changed, 136 insertions, 0 deletions
diff --git a/media-sound/guitarix/Manifest b/media-sound/guitarix/Manifest
index 4849f9e8b355..e406bbe9448d 100644
--- a/media-sound/guitarix/Manifest
+++ b/media-sound/guitarix/Manifest
@@ -1 +1,2 @@
DIST guitarix2-0.44.1.tar.xz 71754176 BLAKE2B 57a1ad0be133fe2851ff7539d5c467a649774a1de90569e83feeb3ba2b05324ce0ee6d4388122cdb3fdcb36afac4cb7cfd2d6ab0216ff2f56d8e7c2886d14152 SHA512 d2c0e40762d97ed7ce61c3115fc3800cc569a2bb4f66e09147507a9eaa815fb9d1363444353a5854035755bd1b1e247ccb341aed60ca0ecf6a77019da73064c1
+DIST guitarix2-0.45.0.tar.xz 75575216 BLAKE2B dfe65b3cdab6cf30c808b65d4d9280617d5b9b9d0227bb6b60b68ac52e64fb34903fdfb3084ebf790630b60a54cfd1f0b170b209b8dfb5c0f23f1d8084e3c342 SHA512 be894076f5b016cb8feb243294e8277f893f7e7054c91353f1a82e9b41ef1bc8c97714c4b6cf9765ee6ab1cff91d02f3a0abe525985922dcde788011a88b9cf4
diff --git a/media-sound/guitarix/files/guitarix-0.45.0-fix-flto.patch b/media-sound/guitarix/files/guitarix-0.45.0-fix-flto.patch
new file mode 100644
index 000000000000..8f832da0c102
--- /dev/null
+++ b/media-sound/guitarix/files/guitarix-0.45.0-fix-flto.patch
@@ -0,0 +1,11 @@
+--- a/waftools/cpu_optimization.py
++++ b/waftools/cpu_optimization.py
+@@ -168,7 +168,7 @@ def configure(conf):
+ conf.env['OPT'] = False
+ cpu_model = append_optimization_flags(conf, cxxflags)
+
+- if '-flto' in cxxflags:
++ if any(x.startswith('-flto') for x in cxxflags):
+ conf.env['LTO'] = True
+ cxxflags.append ("-ffat-lto-objects")
+
diff --git a/media-sound/guitarix/files/guitarix-0.45.0-nostrip.patch b/media-sound/guitarix/files/guitarix-0.45.0-nostrip.patch
new file mode 100644
index 000000000000..e26256ae7aa0
--- /dev/null
+++ b/media-sound/guitarix/files/guitarix-0.45.0-nostrip.patch
@@ -0,0 +1,30 @@
+--- a/waftools/lv2.py
++++ b/waftools/lv2.py
+@@ -40,7 +40,7 @@ def lv2_add_common(tg, target, install_path, defines=None, linkflags=None, cxxfl
+ @Configure.conf
+ def lv2(bld, *k, **kw):
+ lv2_base, dst = get_lv2_base(bld, kw)
+- tg = bld.shlib(features='strip', *k, **kw)
++ tg = bld.shlib(*k, **kw)
+ cxxflags = []
+ if not bld.env['OPT'] and bld.env['SSE2']:
+ cxxflags = [ "-msse2", "-mfpmath=sse"]
+@@ -57,7 +57,7 @@ def lv2_gui(bld, *k, **kw):
+ if not bld.env['LV2GUI']:
+ return None
+ lv2_base, dst = get_lv2_base(bld, kw)
+- tg = bld.shlib(features='strip', *k, **kw)
++ tg = bld.shlib(*k, **kw)
+ lv2_add_common(tg, lv2_base+'_gui', dst, ["LV2_GUI"], bld.env['OS_LV2_CXXFLAGS'])
+ return tg
+
+--- a/wscript
++++ b/wscript
+@@ -418,7 +418,6 @@ def configure(conf):
+ conf.env['DESKAPPS_DIR'] = os.path.normpath(os.path.join(conf.env['SHAREDIR'], 'applications'))
+ conf.env['BIN_NAME'] = APPNAME
+ if opt.lv2:
+- conf.gxload('strip')
+ conf.gxload('lv2')
+ conf.env['LADSPA'] = opt.ladspa
+ conf.env['NEW_LADSPA'] = opt.new_ladspa
diff --git a/media-sound/guitarix/guitarix-0.45.0.ebuild b/media-sound/guitarix/guitarix-0.45.0.ebuild
new file mode 100644
index 000000000000..c4af772b55e0
--- /dev/null
+++ b/media-sound/guitarix/guitarix-0.45.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit multiprocessing python-any-r1 waf-utils xdg
+
+DESCRIPTION="Virtual guitar amplifier for Linux"
+HOMEPAGE="https://guitarix.org/"
+SRC_URI="https://github.com/brummer10/${PN}/releases/download/V${PV}/guitarix2-${PV}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bluetooth debug lv2 nls nsm +standalone zeroconf"
+REQUIRED_USE="|| ( lv2 standalone )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ media-libs/libsndfile
+ media-libs/zita-convolver:=
+ media-libs/zita-resampler
+ net-misc/curl
+ sci-libs/fftw:3.0=
+ x11-libs/gtk+:3
+ lv2? ( media-libs/lv2 )
+ standalone? (
+ dev-libs/boost:=
+ media-libs/liblrdf
+ media-libs/lilv
+ virtual/jack
+ bluetooth? ( net-wireless/bluez )
+ nsm? ( media-libs/liblo )
+ zeroconf? ( net-dns/avahi )
+ )
+"
+# roboto fonts are required for correct ui rendering
+RDEPEND="
+ ${DEPEND}
+ standalone? (
+ media-fonts/roboto
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ standalone? (
+ dev-lang/sassc
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+ )
+"
+
+DOCS=( changelog README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45.0-nostrip.patch
+ "${FILESDIR}"/${PN}-0.45.0-fix-flto.patch
+)
+
+src_configure() {
+ export -n {CXX,LD}FLAGS
+
+ local myconf=(
+ --cxxflags="${CXXFLAGS}"
+ --cxxflags-debug=""
+ --cxxflags-release="-DNDEBUG"
+ --ldflags="${LDFLAGS}"
+ --enable-lfs
+ --lib-dev
+ --no-desktop-update
+ --no-faust
+ --no-ldconfig
+ --shared-lib
+ --jobs=$(makeopts_jobs)
+ $(use_enable nls)
+ $(usex bluetooth "" "--no-bluez")
+ $(usex debug "--debug" "")
+ $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui")
+ $(usex nsm "" "--no-nsm")
+ $(usex standalone "" "--no-standalone")
+ $(usex zeroconf "" "--no-avahi")
+ )
+ waf-utils_src_configure "${myconf[@]}"
+}