summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-24 00:31:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 11:09:36 +0100
commit8757085ff45841a5801ef65faa258bb2866233d8 (patch)
treef1892d691daa00dac9e4a11b570f96b2e4218ae0 /media-sound
parentprofiles: Unmask app-text/poppler-0.84.0 (diff)
downloadgentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.gz
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.bz2
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.zip
*/*: Switch polynomial-c maintained packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/clementine/clementine-1.3.1_p20190127.ebuild6
-rw-r--r--media-sound/clementine/clementine-1.3.1_p20190609.ebuild6
-rw-r--r--media-sound/clementine/clementine-1.3.1_p20191004.ebuild6
-rw-r--r--media-sound/clementine/clementine-9999.ebuild6
-rw-r--r--media-sound/lmms/lmms-1.2.0.ebuild8
-rw-r--r--media-sound/lmms/lmms-1.2.1.ebuild8
-rw-r--r--media-sound/lmms/lmms-9999.ebuild8
-rw-r--r--media-sound/pamix/pamix-9999.ebuild4
8 files changed, 26 insertions, 26 deletions
diff --git a/media-sound/clementine/clementine-1.3.1_p20190127.ebuild b/media-sound/clementine/clementine-1.3.1_p20190127.ebuild
index 9aa4ffa1983b..a2bb0b39fd2e 100644
--- a/media-sound/clementine/clementine-1.3.1_p20190127.ebuild
+++ b/media-sound/clementine/clementine-1.3.1_p20190127.ebuild
@@ -15,7 +15,7 @@ else
SRC_URI="https://github.com/${PN}-player/${PN^}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="amd64 x86"
fi
-inherit cmake-utils flag-o-matic l10n virtualx xdg
+inherit cmake flag-o-matic l10n virtualx xdg
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
@@ -108,7 +108,7 @@ DOCS=( Changelog README.md )
src_prepare() {
l10n_find_plocales_changes "src/translations" "" ".po"
- cmake-utils_src_prepare
+ cmake_src_prepare
# some tests fail or hang
sed -i \
-e '/add_test_file(translations_test.cpp/d' \
@@ -158,7 +158,7 @@ src_configure() {
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/media-sound/clementine/clementine-1.3.1_p20190609.ebuild b/media-sound/clementine/clementine-1.3.1_p20190609.ebuild
index c1abcfd676e4..3e212f782448 100644
--- a/media-sound/clementine/clementine-1.3.1_p20190609.ebuild
+++ b/media-sound/clementine/clementine-1.3.1_p20190609.ebuild
@@ -16,7 +16,7 @@ else
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN^}-${COMMIT}"
fi
-inherit cmake-utils flag-o-matic l10n virtualx xdg
+inherit cmake flag-o-matic l10n virtualx xdg
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
@@ -109,7 +109,7 @@ PATCHES=( "${FILESDIR}/${P}-fix-restore-from-systray.patch" )
src_prepare() {
l10n_find_plocales_changes "src/translations" "" ".po"
- cmake-utils_src_prepare
+ cmake_src_prepare
# some tests fail or hang
sed -i \
-e '/add_test_file(translations_test.cpp/d' \
@@ -159,7 +159,7 @@ src_configure() {
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/media-sound/clementine/clementine-1.3.1_p20191004.ebuild b/media-sound/clementine/clementine-1.3.1_p20191004.ebuild
index f2d1766fb153..4e52840045fa 100644
--- a/media-sound/clementine/clementine-1.3.1_p20191004.ebuild
+++ b/media-sound/clementine/clementine-1.3.1_p20191004.ebuild
@@ -16,7 +16,7 @@ else
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN^}-${COMMIT}"
fi
-inherit cmake-utils flag-o-matic l10n virtualx xdg
+inherit cmake flag-o-matic l10n virtualx xdg
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
@@ -101,7 +101,7 @@ DOCS=( Changelog README.md )
src_prepare() {
l10n_find_plocales_changes "src/translations" "" ".po"
- cmake-utils_src_prepare
+ cmake_src_prepare
# some tests fail or hang
sed -i \
-e '/add_test_file(translations_test.cpp/d' \
@@ -151,7 +151,7 @@ src_configure() {
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/media-sound/clementine/clementine-9999.ebuild b/media-sound/clementine/clementine-9999.ebuild
index 3efe963fe1b3..be99d91ad509 100644
--- a/media-sound/clementine/clementine-9999.ebuild
+++ b/media-sound/clementine/clementine-9999.ebuild
@@ -14,7 +14,7 @@ else
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN^}-${COMMIT}"
fi
-inherit cmake-utils flag-o-matic l10n virtualx xdg
+inherit cmake flag-o-matic l10n virtualx xdg
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
@@ -98,7 +98,7 @@ DOCS=( Changelog README.md )
src_prepare() {
l10n_find_plocales_changes "src/translations" "" ".po"
- cmake-utils_src_prepare
+ cmake_src_prepare
# some tests fail or hang
sed -i \
-e '/add_test_file(translations_test.cpp/d' \
@@ -148,7 +148,7 @@ src_configure() {
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
diff --git a/media-sound/lmms/lmms-1.2.0.ebuild b/media-sound/lmms/lmms-1.2.0.ebuild
index d5f82bfff2a3..e489666c90fe 100644
--- a/media-sound/lmms/lmms-1.2.0.ebuild
+++ b/media-sound/lmms/lmms-1.2.0.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-# The order is important here! Both, cmake-utils and xdg define src_prepare.
-# We need the one from cmake-utils
-inherit xdg cmake-utils
+# The order is important here! Both, cmake and xdg define src_prepare.
+# We need the one from cmake
+inherit xdg cmake
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -90,7 +90,7 @@ src_configure() {
-DWANT_VST=$(usex vst)
-DWANT_SF2=$(usex fluidsynth)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/media-sound/lmms/lmms-1.2.1.ebuild b/media-sound/lmms/lmms-1.2.1.ebuild
index d5f82bfff2a3..e489666c90fe 100644
--- a/media-sound/lmms/lmms-1.2.1.ebuild
+++ b/media-sound/lmms/lmms-1.2.1.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-# The order is important here! Both, cmake-utils and xdg define src_prepare.
-# We need the one from cmake-utils
-inherit xdg cmake-utils
+# The order is important here! Both, cmake and xdg define src_prepare.
+# We need the one from cmake
+inherit xdg cmake
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -90,7 +90,7 @@ src_configure() {
-DWANT_VST=$(usex vst)
-DWANT_SF2=$(usex fluidsynth)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/media-sound/lmms/lmms-9999.ebuild b/media-sound/lmms/lmms-9999.ebuild
index 66d6fbe1e437..376874f97b14 100644
--- a/media-sound/lmms/lmms-9999.ebuild
+++ b/media-sound/lmms/lmms-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-# The order is important here! Both, cmake-utils and xdg define src_prepare.
-# We need the one from cmake-utils
-inherit xdg cmake-utils
+# The order is important here! Both, cmake and xdg define src_prepare.
+# We need the one from cmake
+inherit xdg cmake
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -90,7 +90,7 @@ src_configure() {
-DWANT_VST=$(usex vst)
-DWANT_SF2=$(usex fluidsynth)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_preinst() {
diff --git a/media-sound/pamix/pamix-9999.ebuild b/media-sound/pamix/pamix-9999.ebuild
index b4f4397507df..1e8fad344924 100644
--- a/media-sound/pamix/pamix-9999.ebuild
+++ b/media-sound/pamix/pamix-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ "${PV}" == 9999 ]] ; then
inherit git-r3
@@ -34,5 +34,5 @@ src_configure() {
local mycmakeargs=(
-DWITH_UNICODE="$(usex unicode)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}