summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 15:32:11 -0400
committerSam James <sam@gentoo.org>2024-03-18 05:29:47 +0000
commitbf144807494b6c07da7396f695ad9e61b849a1d1 (patch)
tree985a3486b3b41aa7f6069f4fd6e4670957c90771 /media-sound
parentapp-misc/logiops: mark as LTO-unsafe (diff)
downloadgentoo-bf144807494b6c07da7396f695ad9e61b849a1d1.tar.gz
gentoo-bf144807494b6c07da7396f695ad9e61b849a1d1.tar.bz2
gentoo-bf144807494b6c07da7396f695ad9e61b849a1d1.zip
media-sound/mac: mark as LTO-unsafe, strict-aliasing unsafe
Pending an update to 10.56 which will switch to a memcpy access and will come "soon". Already committed to svn. Closes: https://bugs.gentoo.org/927060 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mac/mac-10.46.ebuild17
-rw-r--r--media-sound/mac/mac-10.53.ebuild17
2 files changed, 32 insertions, 2 deletions
diff --git a/media-sound/mac/mac-10.46.ebuild b/media-sound/mac/mac-10.46.ebuild
index 3f3e26502daf..13bf6f9d8ef3 100644
--- a/media-sound/mac/mac-10.46.ebuild
+++ b/media-sound/mac/mac-10.46.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Monkey's Audio Codecs"
HOMEPAGE="https://www.monkeysaudio.com"
@@ -27,3 +27,18 @@ PATCHES=(
"${FILESDIR}/${PN}-10.18-linux.patch"
"${FILESDIR}/${PN}-10.43-output.patch"
)
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/927060
+ #
+ # Upstream contact method is via email. I sent an email detailing the issue
+ # and got a fast response with a fix. "I'm hoping to do a build soon with a
+ # new open source certificate. I can sure include this."
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ cmake_src_configure
+}
diff --git a/media-sound/mac/mac-10.53.ebuild b/media-sound/mac/mac-10.53.ebuild
index 4315a96dd755..74c128c6dd94 100644
--- a/media-sound/mac/mac-10.53.ebuild
+++ b/media-sound/mac/mac-10.53.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Monkey's Audio Codecs"
HOMEPAGE="https://www.monkeysaudio.com"
@@ -27,3 +27,18 @@ PATCHES=(
"${FILESDIR}/${PN}-10.18-linux.patch"
"${FILESDIR}/${PN}-10.52-output.patch"
)
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/927060
+ #
+ # Upstream contact method is via email. I sent an email detailing the issue
+ # and got a fast response with a fix. "I'm hoping to do a build soon with a
+ # new open source certificate. I can sure include this."
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ cmake_src_configure
+}