summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-01-08 20:33:01 +0200
committerMart Raudsepp <leio@gentoo.org>2019-01-08 20:36:08 +0200
commitc544177b6e9dbcdd995b26a840cfd19477951533 (patch)
tree373f1f562080da90b9e2fa72ebfe9b438d46b4f7 /media-sound
parentmedia-libs/libldac: last commit needed revbump (diff)
downloadgentoo-c544177b6e9dbcdd995b26a840cfd19477951533.tar.gz
gentoo-c544177b6e9dbcdd995b26a840cfd19477951533.tar.bz2
gentoo-c544177b6e9dbcdd995b26a840cfd19477951533.zip
Revert "media-sound/pulseaudio: import bluetooth extra codecs"
This reverts unauthorized commit 7ea8d613021272d4b4cdd0e4e90fae5ebb725044. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio-modules-bt/metadata.xml7
-rw-r--r--media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild34
-rw-r--r--media-sound/pulseaudio/Manifest1
-rw-r--r--media-sound/pulseaudio/metadata.xml4
-rw-r--r--media-sound/pulseaudio/pulseaudio-12.2.ebuild31
5 files changed, 48 insertions, 29 deletions
diff --git a/media-sound/pulseaudio-modules-bt/metadata.xml b/media-sound/pulseaudio-modules-bt/metadata.xml
new file mode 100644
index 000000000000..38b28ff6e621
--- /dev/null
+++ b/media-sound/pulseaudio-modules-bt/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>zx2c4@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
new file mode 100644
index 000000000000..23b537c2088d
--- /dev/null
+++ b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 cmake-utils
+
+DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth (alongside SBC and native+ofono headset)"
+HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/EHfive/${PN}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ media-libs/fdk-aac
+ virtual/ffmpeg
+ media-libs/sbc
+ media-libs/libldac
+ >=net-wireless/bluez-5
+ >=sys-apps/dbus-1.0.0
+ >=net-misc/ofono-1.13
+ media-sound/pulseaudio[-bluetooth]
+"
+# Ordinarily media-libs/libldac should be in DEPEND too, but for now upstream repo is using a ldac submodule instead.
+
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+mycmakeargs=( -DFORCE_NOT_BUILD_LDAC=ON )
diff --git a/media-sound/pulseaudio/Manifest b/media-sound/pulseaudio/Manifest
index 49218c625765..51ef3ffb0939 100644
--- a/media-sound/pulseaudio/Manifest
+++ b/media-sound/pulseaudio/Manifest
@@ -1,2 +1 @@
-DIST patch-1.0-pulseaudio-12.2-bluez5-a2dp-extra-codecs.patch 229249 BLAKE2B fc486e5c6deb0097d66f53e21ac4e901d8312ec03062d15b7e907cf48a606851499cb01328fc6c3c9aac4c7f1929f3132bf2da3c9b4c3d7f6db1017c64360a27 SHA512 a4be9367c09d9f51c2ff90ba524b1051858d23a4249a348a7b7913c671819725f135a861ee33e7c0d879d2cbfed1ef5ae225f94808529958f68dc5a05f306188
DIST pulseaudio-12.2.tar.xz 1665092 BLAKE2B 2e36efc5142c1e379cc2b135f4126f03a31831b26efe60f7cdf128af6e23fab25706a5609644d0b387530021055f87525fe60d527cd3a087f51bfd58e810644f SHA512 877754c1838b3cb042dbc18a5f1cc3cf313ffcaee7a64703330406d1f86279c34f1107634ac3083b158365e6757fbacf5ec406bc3c5788d291de67b77a561a4e
diff --git a/media-sound/pulseaudio/metadata.xml b/media-sound/pulseaudio/metadata.xml
index 87d676f99f0a..a0d16e0c7810 100644
--- a/media-sound/pulseaudio/metadata.xml
+++ b/media-sound/pulseaudio/metadata.xml
@@ -72,9 +72,5 @@
<flag name="ofono-headset">
Build with oFono HFP backend for bluez 5, requires <pkg>net-misc/ofono</pkg>.
</flag>
- <flag name="bluetooth-extra-codecs">
- Build support for extra Bluetooth codecs, like LDAC, APTX, APTX-HD, and AAC, using:
- https://github.com/EHfive/pulseaudio-modules-bt
- </flag>
</use>
</pkgmetadata>
diff --git a/media-sound/pulseaudio/pulseaudio-12.2.ebuild b/media-sound/pulseaudio/pulseaudio-12.2.ebuild
index b3877d084c42..9c17d6d71b00 100644
--- a/media-sound/pulseaudio/pulseaudio-12.2.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-12.2.ebuild
@@ -1,18 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit bash-completion-r1 flag-o-matic gnome2-utils linux-info systemd user udev multilib-minimal autotools
-
-EXTRA_CODECS_VERSION="1.0"
-EXTRA_CODECS_FILE="patch-${EXTRA_CODECS_VERSION}-pulseaudio-${PV}-bluez5-a2dp-extra-codecs.patch"
+inherit bash-completion-r1 flag-o-matic gnome2-utils linux-info systemd user udev multilib-minimal
DESCRIPTION="A networked sound server with an advanced plugin system"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
-SRC_URI="
- https://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz
- bluetooth-extra-codecs? ( https://github.com/EHfive/pulseaudio-modules-bt/releases/download/v${EXTRA_CODECS_VERSION}/${EXTRA_CODECS_FILE} )
-"
+SRC_URI="https://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz"
# libpulse-simple and libpulse link to libpulse-core; this is daemon's
# library and can link to gdbm and other GPL-only libraries. In this
@@ -24,15 +18,14 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
# +alsa-plugin as discussed in bug #519530
-IUSE="+alsa +alsa-plugin +asyncns bluetooth bluetooth-extra-codecs +caps dbus doc
-equalizer gconf +gdbm +glib gtk ipv6 jack libsamplerate libressl lirc native-headset
-neon ofono-headset +orc oss qt5 realtime selinux sox ssl systemd system-wide tcpd test
-+udev +webrtc-aec +X zeroconf"
+IUSE="+alsa +alsa-plugin +asyncns bluetooth +caps dbus doc equalizer gconf +gdbm
++glib gtk ipv6 jack libsamplerate libressl lirc native-headset neon ofono-headset
++orc oss qt5 realtime selinux sox ssl systemd system-wide tcpd test +udev
++webrtc-aec +X zeroconf"
# See "*** BLUEZ support not found (requires D-Bus)" in configure.ac
REQUIRED_USE="
bluetooth? ( dbus )
- bluetooth-extra-codecs? ( bluetooth )
equalizer? ( dbus )
ofono-headset? ( bluetooth )
native-headset? ( bluetooth )
@@ -69,11 +62,6 @@ CDEPEND="
>=net-wireless/bluez-5
>=sys-apps/dbus-1.0.0
media-libs/sbc
- bluetooth-extra-codecs? (
- media-libs/fdk-aac
- virtual/ffmpeg
- media-libs/libldac
- )
)
asyncns? ( net-libs/libasyncns[${MULTILIB_USEDEP}] )
udev? ( >=virtual/udev-143[hwdb(+)] )
@@ -165,11 +153,6 @@ src_prepare() {
# Skip test that cannot work with sandbox, bug #501846
sed -i -e '/lock-autospawn-test /d' src/Makefile.am || die
sed -i -e 's/lock-autospawn-test$(EXEEXT) //' src/Makefile.in || die
-
- if use bluetooth-extra-codecs; then
- eapply "${DISTDIR}/${EXTRA_CODECS_FILE}"
- eautoreconf
- fi
}
multilib_src_configure() {