summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-02 02:02:24 +0100
committerSam James <sam@gentoo.org>2022-09-02 02:07:10 +0100
commit4b65b862e51fbd4c8de5d394b3fbd2323a933785 (patch)
tree1b2bc3f3383abdddfe345ee1bdb81f77a8ca04e0 /media-video/bino/bino-1.6.8.ebuild
parentmedia-video/bino: fix musl build w/ gcc-12 (diff)
downloadgentoo-4b65b862e51fbd4c8de5d394b3fbd2323a933785.tar.gz
gentoo-4b65b862e51fbd4c8de5d394b3fbd2323a933785.tar.bz2
gentoo-4b65b862e51fbd4c8de5d394b3fbd2323a933785.zip
media-video/bino: respect AR
Closes: https://bugs.gentoo.org/804486 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/bino/bino-1.6.8.ebuild')
-rw-r--r--media-video/bino/bino-1.6.8.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-video/bino/bino-1.6.8.ebuild b/media-video/bino/bino-1.6.8.ebuild
index f0f6a54eb8d1..b304712373c8 100644
--- a/media-video/bino/bino-1.6.8.ebuild
+++ b/media-video/bino/bino-1.6.8.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils xdg
+inherit autotools flag-o-matic qmake-utils xdg
DESCRIPTION="Stereoscopic and multi-display media player"
HOMEPAGE="https://bino3d.org/"
@@ -32,8 +32,16 @@ BDEPEND="sys-devel/gettext
PATCHES=(
"${FILESDIR}"/${PN}-1.6.8-time-include.patch
+ "${FILESDIR}"/${PN}-1.6.8-respect-AR.patch
)
+src_prepare() {
+ default
+
+ # Needed for AR patch
+ eautoreconf
+}
+
src_configure() {
if use video_cards_nvidia; then
append-cppflags "-I${ESYSROOT}/usr/include/NVCtrl"