summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-23 12:50:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-23 12:51:48 +0200
commit2de0a12bf5421a968a8e310a090b82f43193644d (patch)
tree9ba20def76282221c2fb22adf6fa19f054ed9cb3 /media-video/libva-utils/libva-utils-2.9.1.ebuild
parentx11-libs/libva: bump to 2.9.0 (diff)
downloadgentoo-2de0a12bf5421a968a8e310a090b82f43193644d.tar.gz
gentoo-2de0a12bf5421a968a8e310a090b82f43193644d.tar.bz2
gentoo-2de0a12bf5421a968a8e310a090b82f43193644d.zip
media-video/libva-utils: bump to 2.9.1
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/libva-utils/libva-utils-2.9.1.ebuild')
-rw-r--r--media-video/libva-utils/libva-utils-2.9.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-video/libva-utils/libva-utils-2.9.1.ebuild b/media-video/libva-utils/libva-utils-2.9.1.ebuild
new file mode 100644
index 000000000000..61b1748bbee5
--- /dev/null
+++ b/media-video/libva-utils/libva-utils-2.9.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then # Live ebuild
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/libva-utils"
+fi
+inherit autotools
+
+DESCRIPTION="Collection of utilities and tests for VA-API"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [[ ${PV} != *9999* ]] ; then
+ SRC_URI="https://github.com/intel/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+drm test wayland X"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="|| ( drm wayland X )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ >=x11-libs/libva-2.0.0:=[drm?,wayland?,X?]
+ drm? ( >=x11-libs/libdrm-2.4 )
+ wayland? ( >=dev-libs/wayland-1.0.6 )
+ X? (
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( NEWS )
+
+src_prepare() {
+ default
+ sed -e 's/-Werror//' -i test/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable drm)
+ $(use_enable test tests)
+ $(use_enable wayland)
+ $(use_enable X x11)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ [[ ${PV} = *9999* ]] && DOCS+=( CONTRIBUTING.md README.md )
+ default
+}