summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-06 20:33:53 +0000
committerSam James <sam@gentoo.org>2022-01-06 20:53:30 +0000
commit422e7ff15be8fcb48d90dea3d7dca0c2833938fc (patch)
tree555aab0d626bbcacd72e2f104cf428d54af52bad /media-video/pipewire/pipewire-9999.ebuild
parentdev-python/pymongo: Remove old (diff)
downloadgentoo-422e7ff15be8fcb48d90dea3d7dca0c2833938fc.tar.gz
gentoo-422e7ff15be8fcb48d90dea3d7dca0c2833938fc.tar.bz2
gentoo-422e7ff15be8fcb48d90dea3d7dca0c2833938fc.zip
media-video/pipewire: add 0.3.43
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/pipewire/pipewire-9999.ebuild')
-rw-r--r--media-video/pipewire/pipewire-9999.ebuild21
1 files changed, 17 insertions, 4 deletions
diff --git a/media-video/pipewire/pipewire-9999.ebuild b/media-video/pipewire/pipewire-9999.ebuild
index e74fc97557fb..321e1eecdb7d 100644
--- a/media-video/pipewire/pipewire-9999.ebuild
+++ b/media-video/pipewire/pipewire-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="Multimedia processing graphs"
@@ -21,7 +21,7 @@ HOMEPAGE="https://pipewire.org/"
LICENSE="MIT LGPL-2.1+ GPL-2"
# ABI was broken in 0.3.42 for https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/49
SLOT="0/0.4"
-IUSE="bluetooth doc echo-cancel extra gstreamer jack-client jack-sdk pipewire-alsa systemd test v4l"
+IUSE="bluetooth doc echo-cancel extra gstreamer jack-client jack-sdk libusb pipewire-alsa ssl systemd test v4l zeroconf"
# Once replacing system JACK libraries is possible, it's likely that
# jack-client IUSE will need blocking to avoid users accidentally
@@ -72,13 +72,16 @@ RDEPEND="
!media-sound/jack-audio-connection-kit
!media-sound/jack2
)
+ libusb? ( virtual/libusb:1 )
pipewire-alsa? (
>=media-libs/alsa-lib-1.1.7[${MULTILIB_USEDEP}]
!media-plugins/alsa-plugins[${MULTILIB_USEDEP},pulseaudio]
)
!pipewire-alsa? ( media-plugins/alsa-plugins[${MULTILIB_USEDEP},pulseaudio] )
+ ssl? ( dev-libs/openssl:= )
systemd? ( sys-apps/systemd )
v4l? ( media-libs/libv4l )
+ zeroconf? ( net-dns/avahi )
"
DEPEND="${RDEPEND}"
@@ -101,6 +104,9 @@ DOCS=( {README,INSTALL}.md NEWS )
PATCHES=(
"${FILESDIR}"/${PN}-0.3.25-enable-failed-mlock-warning.patch
+
+ # Upstream patches/backports
+ "${FILESDIR}"/${P}-systemd-user-unit-dir.patch
)
# limitsdfile related code taken from =sys-auth/realtime-base-0.1
@@ -127,6 +133,7 @@ src_prepare() {
multilib_src_configure() {
local emesonargs=(
-Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(meson_native_use_feature zeroconf avahi)
$(meson_native_use_feature doc docs)
$(meson_native_enabled examples) # TODO: Figure out if this is still important now that media-session gone
$(meson_native_enabled man)
@@ -135,7 +142,11 @@ multilib_src_configure() {
$(meson_native_use_feature gstreamer)
$(meson_native_use_feature gstreamer gstreamer-device-provider)
$(meson_native_use_feature systemd)
+
-Dsystemd-system-service=disabled # Matches upstream
+ -Dsystemd-system-unit-dir="$(systemd_get_systemunitdir)"
+ -Dsystemd-user-unit-dir="$(systemd_get_userunitdir)"
+
$(meson_native_use_feature systemd systemd-user-service)
$(meson_feature pipewire-alsa) # Allows integrating ALSA apps into PW graph
-Dspa-plugins=enabled
@@ -163,6 +174,8 @@ multilib_src_configure() {
-Dtest=disabled # fakesink and fakesource plugins
$(meson_native_use_feature v4l v4l2)
-Dlibcamera=disabled # libcamera is not in Portage tree
+ $(meson_native_use_feature ssl raop)
+ $(meson_native_use_feature libusb)
-Dvideoconvert=enabled # Matches upstream
-Dvideotestsrc=enabled # Matches upstream
-Dvolume=enabled # Matches upstream