summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-15 02:30:11 +0100
committerSam James <sam@gentoo.org>2024-07-15 02:38:27 +0100
commit4049e82eba60893caa1c41c0ee545d529a96b6de (patch)
tree54dffb4dd668314b9d75be1787bd19307fc269db /media-video/subliminal
parentdev-python/srt: new package, add 3.5.3 (diff)
downloadgentoo-4049e82eba60893caa1c41c0ee545d529a96b6de.tar.gz
gentoo-4049e82eba60893caa1c41c0ee545d529a96b6de.tar.bz2
gentoo-4049e82eba60893caa1c41c0ee545d529a96b6de.zip
media-video/subliminal: add 2.2.1
Closes: https://bugs.gentoo.org/740064 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/subliminal')
-rw-r--r--media-video/subliminal/Manifest1
-rw-r--r--media-video/subliminal/subliminal-2.2.1.ebuild84
-rw-r--r--media-video/subliminal/subliminal-9999.ebuild67
3 files changed, 111 insertions, 41 deletions
diff --git a/media-video/subliminal/Manifest b/media-video/subliminal/Manifest
index 0b09ed7b8e8d..610eecca1835 100644
--- a/media-video/subliminal/Manifest
+++ b/media-video/subliminal/Manifest
@@ -1,2 +1,3 @@
DIST matroska_test_w1_1.zip 184550509 BLAKE2B f111725aa08267661942072c2d4ac019d3d322c4e933aad10afb3aa6f69bb3469114c4400d161e53d8a7618b818b22465177460003804a7ac3e69fa4f4db000d SHA512 f170a8e83dab15228f992b3692330163da2402b8e436c7fa195ac1ecc06cf1eaf1a48d8c99a85c031122c158c2d4006023aae75d5b7805385ba25a6d601cb78f
DIST subliminal-2.1.0.tar.gz 5480458 BLAKE2B 249bdd027d99dfb0b81d939af2dc08f62b52dca2c8618f1006ca76eee41c2443b450076eddc1aa533997beca8cdf9016b884d7eceeebbf4e48ced91dae1a2361 SHA512 9b26ae594895470830547eed604aa5b28b75f590e5be12c2d5a478c5daf798d405f209639bd54dce0565b0e27d1b0daa5bef87dfa8590af61f2ab1e287c41060
+DIST subliminal-2.2.1.gh.tar.gz 3165965 BLAKE2B 9b69547540773d1434117a0e81bebcb3da49f97c145285a2bb2349ff8d6a4cb35f42f8fa8c306d2afedaf0ccff275908526a0f6d6c7ba7846aea6acd2b154b92 SHA512 4e59ccfe42419bb33df395aad6c2255ad03cfe7311fc754ea591be7c9e33ef5cc3e980a1da2839afe79e3b22024b3e7b458b03b4e6270ea8bcadc0337d7e37bf
diff --git a/media-video/subliminal/subliminal-2.2.1.ebuild b/media-video/subliminal/subliminal-2.2.1.ebuild
new file mode 100644
index 000000000000..1aa8338f1813
--- /dev/null
+++ b/media-video/subliminal/subliminal-2.2.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE='xml(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to search and download subtitles"
+HOMEPAGE="https://github.com/Diaoul/subliminal https://pypi.org/project/subliminal/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/Diaoul/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+SRC_URI+=" test? ( https://downloads.sourceforge.net/matroska/test_files/matroska_test_w1_1.zip )"
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="
+ test? (
+ app-arch/unzip
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/babelfish-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/click-option-group-0.5.6[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-1.0[${PYTHON_USEDEP}]
+ >=dev-python/enzyme-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/guessit-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-4.2[${PYTHON_USEDEP}]
+ >=dev-python/pysubs2-1.7[${PYTHON_USEDEP}]
+ >=dev-python/rarfile-2.7[compressed,${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/srt-3.5[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2[${PYTHON_USEDEP}]
+"
+
+EPYTEST_DESELECT=(
+ # Needs network
+ tests/test_core.py::test_scan_archive_with_one_video
+ tests/test_core.py::test_scan_archive_with_multiple_videos
+ tests/test_core.py::test_scan_archive_with_no_video
+ tests/test_core.py::test_scan_password_protected_archive
+
+ # TODO
+ tests/test_core.py::test_refine_video_metadata
+)
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ # Needed to unpack the test data
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+python_prepare_all() {
+ if use test ; then
+ mkdir -p tests/data/mkv || die
+ ln -s "${WORKDIR}"/test*.mkv tests/data/mkv/ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
diff --git a/media-video/subliminal/subliminal-9999.ebuild b/media-video/subliminal/subliminal-9999.ebuild
index 87f5bf683f90..1aa8338f1813 100644
--- a/media-video/subliminal/subliminal-9999.ebuild
+++ b/media-video/subliminal/subliminal-9999.ebuild
@@ -4,31 +4,28 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE='xml(+)'
inherit distutils-r1
+DESCRIPTION="Python library to search and download subtitles"
+HOMEPAGE="https://github.com/Diaoul/subliminal https://pypi.org/project/subliminal/"
+
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
EGIT_BRANCH="develop"
else
- SRC_URI="https://github.com/Diaoul/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ SRC_URI="https://github.com/Diaoul/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
fi
-DESCRIPTION="Python library to search and download subtitles"
-HOMEPAGE="https://github.com/Diaoul/subliminal https://pypi.org/project/subliminal/"
SRC_URI+=" test? ( https://downloads.sourceforge.net/matroska/test_files/matroska_test_w1_1.zip )"
LICENSE="MIT"
SLOT="0"
-# The cassettes have bitrotted a bit as of 2024-06-01 but there's
-# a lot of movement upstream on the 'develop' branch towards a new release.
-RESTRICT="test"
-
BDEPEND="
test? (
app-arch/unzip
@@ -37,26 +34,33 @@ BDEPEND="
)
"
RDEPEND="
- >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
- >=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/babelfish-0.6.1[${PYTHON_USEDEP}]
>=dev-python/beautifulsoup4-4.4.0[${PYTHON_USEDEP}]
- >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/click-4.0[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/click-option-group-0.5.6[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/dogpile-cache-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-1.0[${PYTHON_USEDEP}]
+ >=dev-python/enzyme-0.5.0[${PYTHON_USEDEP}]
>=dev-python/guessit-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/pytz-2012c[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-4.2[${PYTHON_USEDEP}]
+ >=dev-python/pysubs2-1.7[${PYTHON_USEDEP}]
>=dev-python/rarfile-2.7[compressed,${PYTHON_USEDEP}]
>=dev-python/requests-2.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/srt-3.5[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2[${PYTHON_USEDEP}]
"
-PATCHES=(
- "${FILESDIR}"/${P}-fix-pytest-warning.patch
- "${FILESDIR}"/${PN}-2.1.0-rarfile-4.0-compat.patch
+EPYTEST_DESELECT=(
+ # Needs network
+ tests/test_core.py::test_scan_archive_with_one_video
+ tests/test_core.py::test_scan_archive_with_multiple_videos
+ tests/test_core.py::test_scan_archive_with_no_video
+ tests/test_core.py::test_scan_password_protected_archive
+
+ # TODO
+ tests/test_core.py::test_refine_video_metadata
)
distutils_enable_tests pytest
@@ -71,12 +75,6 @@ src_unpack() {
}
python_prepare_all() {
- # Disable code checkers as they require unavailable dependencies.
- sed -i -e 's/--\(pep8\|flakes\)//g' pytest.ini || die
-
- # Disable unconditional dependency on dev-python/pytest-runner.
- sed -i -e "s|'pytest-runner'||g" setup.py || die
-
if use test ; then
mkdir -p tests/data/mkv || die
ln -s "${WORKDIR}"/test*.mkv tests/data/mkv/ || die
@@ -84,16 +82,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- EPYTEST_DESELECT=(
- tests/test_core.py::test_scan_archive_with_one_video
- tests/test_core.py::test_scan_archive_with_multiple_videos
- tests/test_core.py::test_scan_archive_with_no_video
- tests/test_core.py::test_scan_password_protected_archive
- # NotImplementedError
- tests/test_core.py::test_save_subtitles
- )
-
- epytest
-}