summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/xine-ui/xine-ui-0.99.8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/xine-ui/xine-ui-0.99.8.ebuild')
-rw-r--r--media-video/xine-ui/xine-ui-0.99.8.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/media-video/xine-ui/xine-ui-0.99.8.ebuild b/media-video/xine-ui/xine-ui-0.99.8.ebuild
new file mode 100644
index 000000000000..88071fa01363
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.99.8.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime gnome2-utils
+
+DESCRIPTION="Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="aalib curl debug libcaca lirc nls readline vdr X xinerama"
+
+RDEPEND="|| ( app-arch/tar app-arch/libarchive )
+ media-libs/libpng:0=
+ >=media-libs/xine-lib-1.2:=[aalib?,libcaca?]
+ virtual/jpeg:0
+ aalib? ( media-libs/aalib:= )
+ curl? ( >=net-misc/curl-7.10.2:= )
+ libcaca? ( media-libs/libcaca:= )
+ lirc? ( app-misc/lirc:= )
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2:= )
+ X? (
+ x11-libs/libICE:=
+ x11-libs/libSM:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXft:=
+ x11-libs/libXrender:=
+ x11-libs/libXScrnSaver:=
+ x11-libs/libXtst:=
+ x11-libs/libXv:=
+ x11-libs/libXxf86vm:=
+ xinerama? ( x11-libs/libXinerama:= )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.18.3 )
+ X? (
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-readline-6.3.patch
+ rm -f misc/xine-bugreport
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama) \
+ $(use_enable lirc) \
+ $(use_enable vdr vdr-keys) \
+ --disable-nvtvsimple \
+ $(use_enable debug) \
+ $(use_with X x) \
+ $(use_with readline) \
+ $(use_with curl) \
+ $(use_with aalib) \
+ $(use_with libcaca caca) \
+ --without-fb
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ docsdir="/usr/share/doc/${PF}" \
+ install
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}