summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-20 19:26:57 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-20 19:37:24 -0500
commit50cea264a8727a5c672e07efd935a6a21410890b (patch)
treef5973d72ef46fe63ab0d7a1a92f2fe0ba92761a0 /media-video
parentsys-kernel/git-sources: add 6.1_rc6 (diff)
downloadgentoo-50cea264a8727a5c672e07efd935a6a21410890b.tar.gz
gentoo-50cea264a8727a5c672e07efd935a6a21410890b.tar.bz2
gentoo-50cea264a8727a5c672e07efd935a6a21410890b.zip
media-video/setpwc: fix build w/ upcoming clang16
Closes: https://bugs.gentoo.org/874918 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/setpwc/files/setpwc-1.3-clang16.patch8
-rw-r--r--media-video/setpwc/setpwc-1.3.ebuild7
2 files changed, 13 insertions, 2 deletions
diff --git a/media-video/setpwc/files/setpwc-1.3-clang16.patch b/media-video/setpwc/files/setpwc-1.3-clang16.patch
new file mode 100644
index 000000000000..c74eceb09cdb
--- /dev/null
+++ b/media-video/setpwc/files/setpwc-1.3-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/874918
+--- a/setpwc.c
++++ b/setpwc.c
+@@ -348,3 +348,3 @@
+
+-void query_pan_tilt_status(fd)
++void query_pan_tilt_status(int fd)
+ {
diff --git a/media-video/setpwc/setpwc-1.3.ebuild b/media-video/setpwc/setpwc-1.3.ebuild
index cbc20cad7175..74d9c738c038 100644
--- a/media-video/setpwc/setpwc-1.3.ebuild
+++ b/media-video/setpwc/setpwc-1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,10 @@ KEYWORDS="amd64 ~arm ppc x86"
DEPEND="sys-kernel/linux-headers"
-PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
src_configure() {
tc-export CC