summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-02 06:10:43 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-02 06:10:43 +0100
commitaa240655c683eb070932a40e3b0773be307603bf (patch)
treeb68867c228634eab1038a3597c75c7c08c79b09b /net-analyzer/cacti/cacti-0.8.8f-r1.ebuild
parentnet-misc/socat: Stable for HPPA (bug #573602). (diff)
downloadgentoo-aa240655c683eb070932a40e3b0773be307603bf.tar.gz
gentoo-aa240655c683eb070932a40e3b0773be307603bf.tar.bz2
gentoo-aa240655c683eb070932a40e3b0773be307603bf.zip
net-analyzer/cacti: Add upstream patch for CVE-2015-8369 (bug #568400).
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer/cacti/cacti-0.8.8f-r1.ebuild')
-rw-r--r--net-analyzer/cacti/cacti-0.8.8f-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-analyzer/cacti/cacti-0.8.8f-r1.ebuild b/net-analyzer/cacti/cacti-0.8.8f-r1.ebuild
new file mode 100644
index 000000000000..782f24179571
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.8f-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils webapp
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+need_httpd
+
+RDEPEND="
+ dev-lang/php[cli,mysql,session,sockets,xml]
+ dev-php/adodb
+ net-analyzer/rrdtool[graph]
+ virtual/cron
+ virtual/mysql
+ snmp? ( >=net-analyzer/net-snmp-5.2.0 )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-CVE-2015-8369.patch
+
+ sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/global.php || die
+
+ rm -rf lib/adodb || die # don't use bundled adodb
+}
+
+src_compile() { :; }
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE README || die
+ dodoc docs/{CHANGELOG,CONTRIB,README,txt/manual.txt}
+ use doc && dohtml -r docs/html/
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}