summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-05 14:28:54 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-05 14:29:18 +0200
commit26a9869fd006091e2694768dbbec2fa6032a475a (patch)
treecb85a64c0d839f5e885dac7241109fbc03e3864f /net-analyzer/fping/fping-5.0.ebuild
parentdev-lisp/sbcl: bump to 2.0.7 (diff)
downloadgentoo-26a9869fd006091e2694768dbbec2fa6032a475a.tar.gz
gentoo-26a9869fd006091e2694768dbbec2fa6032a475a.tar.bz2
gentoo-26a9869fd006091e2694768dbbec2fa6032a475a.zip
net-analyzer/fping: Version 5.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/fping/fping-5.0.ebuild')
-rw-r--r--net-analyzer/fping/fping-5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/fping/fping-5.0.ebuild b/net-analyzer/fping/fping-5.0.ebuild
new file mode 100644
index 000000000000..4233263233bf
--- /dev/null
+++ b/net-analyzer/fping/fping-5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit fcaps
+
+DESCRIPTION="A utility to ping multiple hosts at once"
+HOMEPAGE="https://fping.org/ https://github.com/schweikert/fping/"
+SRC_URI="https://fping.org/dist/${P}.tar.gz"
+
+LICENSE="fping"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6 suid"
+
+FILECAPS=( cap_net_raw+ep usr/sbin/fping )
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2-fping6-6.patch
+)
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ if use suid; then
+ fperms u+s /usr/sbin/fping
+ fi
+
+ if use ipv6; then
+ dosym fping /usr/sbin/fping6
+ fi
+}