summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-07 09:12:12 +0000
committerSam James <sam@gentoo.org>2024-11-07 09:12:12 +0000
commitb778b9c1bae96b41ad994b8647eb739e48bb8811 (patch)
treebe6b2a572518c830f8523de4011c3d8989b6c86f /net-analyzer/nsat
parentnet-analyzer/nsat: don't pass -ansi (diff)
downloadgentoo-b778b9c1bae96b41ad994b8647eb739e48bb8811.tar.gz
gentoo-b778b9c1bae96b41ad994b8647eb739e48bb8811.tar.bz2
gentoo-b778b9c1bae96b41ad994b8647eb739e48bb8811.zip
net-analyzer/nsat: update EAPI 7 -> 8, USE=X -> USE=gui
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/nsat')
-rw-r--r--net-analyzer/nsat/nsat-1.5-r7.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-analyzer/nsat/nsat-1.5-r7.ebuild b/net-analyzer/nsat/nsat-1.5-r7.ebuild
index eccfd92a7ab8..e24b1507e0a3 100644
--- a/net-analyzer/nsat/nsat-1.5-r7.ebuild
+++ b/net-analyzer/nsat/nsat-1.5-r7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools toolchain-funcs
@@ -13,7 +13,7 @@ S="${WORKDIR}/${PN}"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-IUSE="X"
+IUSE="gui"
RDEPEND="
dev-libs/libmix
@@ -21,7 +21,7 @@ RDEPEND="
net-libs/libpcap
net-libs/libtirpc:=
net-libs/rpcsvc-proto
- X? (
+ gui? (
dev-lang/tk:*
x11-libs/libX11
)
@@ -59,7 +59,7 @@ src_prepare() {
src_configure() {
tc-export CC
- econf $(use_with X x)
+ econf $(use_with gui x)
}
src_compile() {
@@ -68,7 +68,7 @@ src_compile() {
src_install() {
dobin nsat smb-ns
- use X && dobin tools/xnsat
+ use gui && dobin tools/xnsat
insinto /usr/share/nsat
doins nsat.cgi