summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-08 06:31:37 +0000
committerSam James <sam@gentoo.org>2022-02-08 06:31:45 +0000
commitf885f314661f613af15d46b79217b602fed28472 (patch)
tree0078c5b29058f6469751e1d5cf1461db1b5449e0 /net-analyzer/ntopng/files
parentnet-libs/nDPI: add 4.2 (diff)
downloadgentoo-f885f314661f613af15d46b79217b602fed28472.tar.gz
gentoo-f885f314661f613af15d46b79217b602fed28472.tar.bz2
gentoo-f885f314661f613af15d46b79217b602fed28472.zip
net-analyzer/ntopng: add 5.2.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/ntopng/files')
-rw-r--r--net-analyzer/ntopng/files/ntopng-5.2.1-build-system.patch89
-rw-r--r--net-analyzer/ntopng/files/ntopng-5.2.1-mysqltool.patch17
-rw-r--r--net-analyzer/ntopng/files/ntopng-5.2.1-ndpi-linking.patch13
3 files changed, 119 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/files/ntopng-5.2.1-build-system.patch b/net-analyzer/ntopng/files/ntopng-5.2.1-build-system.patch
new file mode 100644
index 000000000000..ff05d103f22a
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-5.2.1-build-system.patch
@@ -0,0 +1,89 @@
+https://github.com/ntop/ntopng/pull/6288
+
+From 93b62eb0b48f9914fed5511dc2a4289a83a1ed34 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 8 Feb 2022 06:07:21 +0000
+Subject: [PATCH 1/3] build: fail configure if ZMQ can't be found
+
+We already "fail" (makefile won't be generated) when ZMQ can't be found but
+the exit code doesn't represent this until now.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ configure.ac.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac.in b/configure.ac.in
+index b032d7faa34..0b30e9480c7 100644
+--- a/configure.ac.in
++++ b/configure.ac.in
+@@ -132,7 +132,7 @@ if test "x$ac_cv_lib_zmq_zmq_socket_monitor" = xyes; then :
+ AC_DEFINE_UNQUOTED(HAVE_ZMQ, 1, [ZMQ is present])
+ else
+ echo "ZMQ not present or too old (< v. 3.x)"
+- exit
++ exit 1
+ fi
+
+ AC_CHECK_LIB([sodium], [sodium_init], LIBS="${LIBS} -lsodium")
+
+From 75206e5a3fdc289a2229770595fbf588de79402b Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 8 Feb 2022 06:08:02 +0000
+Subject: [PATCH 2/3] build: avoid bashism in configure
+
+[[ ]] and == are both Bashisms and /bin/sh may be a POSIX compliant
+shell (Debian notably uses dash for /bin/sh which wouldn't be
+happy with this).
+
+This will continue to work on Bash.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ configure.ac.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac.in b/configure.ac.in
+index 0b30e9480c7..3dc6ef4a539 100644
+--- a/configure.ac.in
++++ b/configure.ac.in
+@@ -187,7 +187,7 @@ fi
+
+ if [ test -f /usr/bin/lsb_release ]; then
+ CODENAME=`/usr/bin/lsb_release -c|cut -f 2`
+- if [[ $CODENAME == "wheezy" ]]; then :
++ if test $CODENAME = "wheezy" ; then
+ CPPFLAGS="${CPPFLAGS} -DOLD_NETFILTER_INTERFACE=1"
+ fi
+ fi
+
+From 6e355cb98078dbfc379ba178ec99b7e351afdfe9 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 8 Feb 2022 06:09:44 +0000
+Subject: [PATCH 3/3] build: use $(MAKE)
+
+This allows parallel builds to work properly as we'll be calling 'make ...'
+with any additional arguments it internally passes down rather than literally
+just make.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ configure.ac.in | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/configure.ac.in b/configure.ac.in
+index 3dc6ef4a539..3ff06c4efd4 100644
+--- a/configure.ac.in
++++ b/configure.ac.in
+@@ -720,10 +720,7 @@ fi
+
+ AC_DEFINE_UNQUOTED(_CRT_SECURE_NO_WARNINGS, 1, [Disable warning on windows])
+
+-GMAKE=`which gmake`
+-if test x$GMAKE = x; then
+- GMAKE="make"
+-fi
++GMAKE='$(MAKE)'
+
+ GIT=`which git`
+ if test x$GIT = x; then
diff --git a/net-analyzer/ntopng/files/ntopng-5.2.1-mysqltool.patch b/net-analyzer/ntopng/files/ntopng-5.2.1-mysqltool.patch
new file mode 100644
index 000000000000..48551589f022
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-5.2.1-mysqltool.patch
@@ -0,0 +1,17 @@
+--- a/configure.ac.in
++++ b/configure.ac.in
+@@ -596,13 +596,7 @@ if test "${with_nedge+set}" != set; then
+ if test "x$ac_cv_prog_ac_ct_MARIADB" = "xmariadb_config"; then
+ MYSQLTOOL="mariadb_config"
+ else
+- PATH=$PATH:/usr/local/mysql/bin
+- AC_CHECK_TOOL(MYSQL, mysql_config)
+- if test "x$ac_cv_prog_ac_ct_MYSQL" = "xmysql_config"; then
+- MYSQLTOOL="mysql_config"
+- else
+- MYSQLTOOL=""
+- fi
++ MYSQLTOOL="mysql_config"
+ fi
+
+ if test -n "$MYSQLTOOL"; then
diff --git a/net-analyzer/ntopng/files/ntopng-5.2.1-ndpi-linking.patch b/net-analyzer/ntopng/files/ntopng-5.2.1-ndpi-linking.patch
new file mode 100644
index 000000000000..4940cb44b733
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-5.2.1-ndpi-linking.patch
@@ -0,0 +1,13 @@
+--- a/configure.ac.in
++++ b/configure.ac.in
+@@ -236,8 +236,8 @@ fi
+ PKG_CHECK_MODULES([NDPI], [libndpi >= 2.0], [
+ NDPI_INC=`echo $NDPI_CFLAGS | sed -e "s/[ ]*$//"`
+ # Use static libndpi library as building against the dynamic library fails
+- NDPI_LIB="-Wl,-Bstatic $NDPI_LIBS -Wl,-Bdynamic"
+- #NDPI_LIB="$NDPI_LIBS"
++ #NDPI_LIB="-Wl,-Bstatic $NDPI_LIBS -Wl,-Bdynamic"
++ NDPI_LIB="$NDPI_LIBS"
+ NDPI_LIB_DEP=
+ ], [
+ AC_MSG_CHECKING(for nDPI source)