summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/siphon/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/siphon/files')
-rw-r--r--net-analyzer/siphon/files/siphon-666-gentoo.patch19
-rw-r--r--net-analyzer/siphon/files/siphon-666-log.patch46
2 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/siphon/files/siphon-666-gentoo.patch b/net-analyzer/siphon/files/siphon-666-gentoo.patch
new file mode 100644
index 000000000000..eea6d93b802e
--- /dev/null
+++ b/net-analyzer/siphon/files/siphon-666-gentoo.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ CC = gcc
+ CCFLAGS = -Wall -pthread -ggdb
+-CFLAGS = -Wall -O2 -pthread -ggdb -I.
++CFLAGS += -pthread -Wall -I.
+ LIBS = -lpcap
+ OBJS = parse.o sniff.o main.o log.o
+ SRCS = ${OBJS:.o=.c}
+@@ -9,7 +9,7 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CCFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
++ $(CC) $(CCFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+ clean:
+ rm -f $(OBJS) *~ *.core core siphon
diff --git a/net-analyzer/siphon/files/siphon-666-log.patch b/net-analyzer/siphon/files/siphon-666-log.patch
new file mode 100644
index 000000000000..07d2de4d4d12
--- /dev/null
+++ b/net-analyzer/siphon/files/siphon-666-log.patch
@@ -0,0 +1,46 @@
+--- a/main.c
++++ b/main.c
+@@ -98,7 +98,7 @@
+ pti_parse.pti_pd[1] = pd_parse2log[1];
+
+ pthread_create (&parse_thread, NULL, (void *) parse, &pti_parse);
+- pthread_create(&log_thread,NULL,(void *)log, (void *)pd_parse2log[0]);
++ pthread_create(&log_thread,NULL,(void *)siphon_log, (void *)pd_parse2log[0]);
+ pthread_create (&sniff_thread, NULL, (void *) sniff_network,
+ &pd_sniff2parse[1]);
+
+--- a/log.c
++++ b/log.c
+@@ -19,7 +19,7 @@
+
+ int tag = 0;
+
+-void *log(void *pipe)
++void *siphon_log(void *pipe)
+ {
+ struct parse2log *info;
+ char hashed[100], buf[1024], *os, *proto = NULL, *df;
+@@ -137,10 +137,10 @@
+ FILE *osprints;
+ static char line[80], *oswin, *osttl, *osdf, *os, hexed[10];
+ static int check = 0;
+- osprints = fopen("osprints.conf","r");
++ osprints = fopen("/etc/osprints.conf","r");
+
+ if(!osprints) {
+- perror("Unable to find osprints.conf\n");
++ perror("Unable to find /etc/osprints.conf\n");
+ return "Unknown";
+ }
+
+--- a/siphon.h
++++ b/siphon.h
+@@ -49,7 +49,7 @@
+
+ void *sniff_network (void *);
+ void *parse (void *);
+-void *log(void *);
++void *siphon_log(void *);
+
+ char *device, *logfile;
+ int verbose, back;