summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-12-18 14:21:17 +0100
committerMichael Weber <xmw@gentoo.org>2017-12-18 14:22:17 +0100
commit40977ebaba49d5200c18e942b30ac13939c0cc60 (patch)
treec459e5cc5b2a20b9081e1923b2eeaf58107eb441 /net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
parentsci-physics/root: drop unused patches (diff)
downloadgentoo-40977ebaba49d5200c18e942b30ac13939c0cc60.tar.gz
gentoo-40977ebaba49d5200c18e942b30ac13939c0cc60.tar.bz2
gentoo-40977ebaba49d5200c18e942b30ac13939c0cc60.zip
net-analyzer/thc-ipv6: Version bump and add stdint.h include.
Closes: https://bugs.gentoo.org/639826 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild')
-rw-r--r--net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild b/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
index 5151e3d3ceca..a0934cf80b9a 100644
--- a/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
+++ b/net-analyzer/thc-ipv6/thc-ipv6-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,7 +15,7 @@ SLOT="0"
IUSE="ssl"
if [[ ${PV} != *9999 ]]; then
- SRC_URI="http://www.thc.org/releases/${P}.tar.gz"
+ SRC_URI="https://github.com/vanhauser-thc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -24,6 +24,8 @@ DEPEND="net-libs/libpcap
ssl? ( dev-libs/openssl:* )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-3.2-stdint.patch" )
+
src_unpack() {
if [[ ${PV} != *9999 ]]; then
default_src_unpack
@@ -33,15 +35,13 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0-Makefile.patch
- sed -i \
- -e '/^CFLAGS=/s,CFLAGS=,CFLAGS?=,' \
- Makefile
+ sed -e '/^CFLAGS=/s,CFLAGS=,CFLAGS?=,' \
+ -i Makefile || die
if ! use ssl ; then
sed -e '/^HAVE_SSL/s:^:#:' \
-i Makefile
fi
- eapply_user
+ default
}
src_compile() {