summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 02:05:52 +0100
committerSam James <sam@gentoo.org>2021-04-03 17:10:27 +0100
commit083f553c808a48d17f8998591af1fba5733ce643 (patch)
tree4c86e36ff3c40a42c02635e1834ac25fa91603c2 /net-analyzer
parentnet-analyzer/snortalog: port to EAPI 7 (diff)
downloadgentoo-083f553c808a48d17f8998591af1fba5733ce643.tar.gz
gentoo-083f553c808a48d17f8998591af1fba5733ce643.tar.bz2
gentoo-083f553c808a48d17f8998591af1fba5733ce643.zip
net-analyzer/synscan: eutils--, add Darwin + Solaris support
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/synscan/synscan-5.02.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/net-analyzer/synscan/synscan-5.02.ebuild b/net-analyzer/synscan/synscan-5.02.ebuild
index d91e0b3141dd..2da333b19ded 100644
--- a/net-analyzer/synscan/synscan-5.02.ebuild
+++ b/net-analyzer/synscan/synscan-5.02.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools eutils
+
+inherit autotools
DESCRIPTION="A fast asynchronous half-open TCP portscanner"
HOMEPAGE="http://www.digit-labs.org/files/tools/synscan/"
@@ -11,29 +12,29 @@ SRC_URI="http://www.digit-labs.org/files/tools/${PN}/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="kernel_FreeBSD kernel_linux"
+IUSE="kernel_Darwin kernel_FreeBSD kernel_linux kernel_SunOS"
RDEPEND="net-libs/libpcap"
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}/${P}-destdir.patch"
+ "${FILESDIR}"/${P}-destdir.patch
)
src_prepare() {
default
- mv "$S"/configure.in "$S"/configure.ac || die
- eautoconf
-}
-src_configure() {
- econf --prefix="${EPREFIX}"/usr
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_compile() {
local _target
+
use kernel_FreeBSD && _target=freebsd
use kernel_linux && _target=linux
+ use kernel_SunOS && _target=solaris-sparc-gcc
+ use kernel_Darwin && _target=macos
emake ${_target}
}