summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-04 03:44:25 +0100
committerSam James <sam@gentoo.org>2024-04-04 03:44:25 +0100
commit1f92fd8808b9d5239fd4961bde6fd04a4107b3ed (patch)
tree87726fd3fe5cd84cdc61fa1374a26188a5f20b98 /net-analyzer
parentnet-analyzer/wireshark: need dev-libs/libxslt for docs too (diff)
downloadgentoo-1f92fd8808b9d5239fd4961bde6fd04a4107b3ed.tar.gz
gentoo-1f92fd8808b9d5239fd4961bde6fd04a4107b3ed.tar.bz2
gentoo-1f92fd8808b9d5239fd4961bde6fd04a4107b3ed.zip
net-analyzer/wireshark: sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 9797505ac225..4f2a6bd3fbd9 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -23,16 +23,15 @@ else
SRC_URI+=" verify-sig? ( https://www.wireshark.org/download/SIGNATURES-${PV}.txt -> ${P}-signatures.txt )"
S="${WORKDIR}/${P/_/}"
- # 4.1.x is an experimental release until 4.2
- #if [[ ${PV} != *_rc* ]] ; then
- # KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~riscv ~x86"
- #fi
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~hppa"
+ fi
fi
LICENSE="GPL-2"
SLOT="0/${PV}"
IUSE="androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc dpauxmon"
-IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lua lz4 maxminddb"
+IUSE+=" +dumpcap +editcap +gui http2 http3 ilbc kerberos libxml2 lua lz4 maxminddb"
IUSE+=" +mergecap +minizip +netlink opus +plugins +pcap qt6 +randpkt"
IUSE+=" +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl"
IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump wifi zlib +zstd"
@@ -56,6 +55,7 @@ RDEPEND="
ciscodump? ( >=net-libs/libssh-0.6:= )
filecaps? ( sys-libs/libcap )
http2? ( >=net-libs/nghttp2-1.11.0:= )
+ http3? ( net-libs/nghttp3 )
ilbc? ( media-libs/libilbc:= )
kerberos? ( virtual/krb5 )
libxml2? ( dev-libs/libxml2 )
@@ -249,6 +249,7 @@ src_configure() {
-DENABLE_MINIZIP=$(usex minizip)
-DENABLE_NETLINK=$(usex netlink)
-DENABLE_NGHTTP2=$(usex http2)
+ -DENABLE_NGHTTP3=$(usex http3)
-DENABLE_OPUS=$(usex opus)
-DENABLE_PCAP=$(usex pcap)
-DENABLE_PLUGINS=$(usex plugins)