summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-24 20:29:13 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-26 22:16:58 +0300
commit7ff69380d8a100801f5e59a6d46ec14780f2c7e8 (patch)
tree95a7f2dd736eded3a371986aeab2ea96a01303b9 /net-analyzer
parentnet-analyzer/tcping: add 2.1.0 (diff)
downloadgentoo-7ff69380d8a100801f5e59a6d46ec14780f2c7e8.tar.gz
gentoo-7ff69380d8a100801f5e59a6d46ec14780f2c7e8.tar.bz2
gentoo-7ff69380d8a100801f5e59a6d46ec14780f2c7e8.zip
net-analyzer/ssldump: add 1.8
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37707 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ssldump/Manifest1
-rw-r--r--net-analyzer/ssldump/ssldump-1.8.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/ssldump/Manifest b/net-analyzer/ssldump/Manifest
index eb1f4cb13252..72467a1e428d 100644
--- a/net-analyzer/ssldump/Manifest
+++ b/net-analyzer/ssldump/Manifest
@@ -1 +1,2 @@
DIST ssldump-1.5.tar.gz 129388 BLAKE2B 9877bf604690911a3680cf4edfe0115a8a8e2ddf14abc260a99fdcc181bd727c5f3bfb0aa8864f502ff560ccab76e27a22266a3ed78eb516f019ed7cb44bef69 SHA512 4eb84744591539fdaf9b2454d23c917f5e97cb2e5f03e0c38393327caecc72dfc77ee7b734519b1f224a5e3a132185b8fccfeb9186fc9f1b586444fc748a3814
+DIST ssldump-1.8.tar.gz 188219 BLAKE2B e6cff9598e6818eb2192450c0958a7f9bf003d79ad74dd9e60b1af2e977b27a6b3667a5d7ed6fdb1fa836a51c4ab7a6dc2f0c5afb1dbd8b3b08af3cd145a872e SHA512 5435187fa851cddd167a5ee7e79f8051752780512873195b215e8695430282338f22719e6ddd32bd4eae3cc9a385abd44a4b369f93dc201908696aaed214b9bc
diff --git a/net-analyzer/ssldump/ssldump-1.8.ebuild b/net-analyzer/ssldump/ssldump-1.8.ebuild
new file mode 100644
index 000000000000..7cf1c12dd469
--- /dev/null
+++ b/net-analyzer/ssldump/ssldump-1.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="An SSLv3/TLS network protocol analyzer"
+HOMEPAGE="https://github.com/adulau/ssldump/"
+SRC_URI="https://github.com/adulau/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="dev-libs/json-c:=
+ dev-libs/openssl:=
+ net-libs/libnet:1.1
+ net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dosbin "${BUILD_DIR}"/${PN}
+ doman ${PN}.1
+ einstalldocs
+}